{"id":"CVE-2022-31126","state":"PUBLISHED","title":"Unauthenticated Remote Code Execution in Roxy-wi","description":"Roxy-wi is an open source web interface for managing Haproxy, Nginx, Apache and Keepalived servers. A vulnerability in Roxy-wi allows a remote, unauthenticated attacker to code execution by sending a specially crafted HTTP request to /app/options.py file. This affects Roxy-wi versions before 6.1.1.0. Users are advised to upgrade. There are no known workarounds for this issue.","publishedAt":"2022-07-06T17:30:13.000Z","updatedAt":"2025-04-23T18:04:37.698Z","severity":{"score":10,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L","source":"GitHub_M"},"assigner":"GitHub_M","products":["hap-wi roxy-wi"],"affected":[{"vendor":"hap-wi","product":"roxy-wi","versions":[{"version":"< 6.1.1.0","status":"affected"}]}],"references":["https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-mh86-878h-43c9"],"weaknesses":["CWE-74"],"ingestedAt":"2026-10-29T19:50:06.617Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/31xxx/CVE-2022-31126.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-31126","state":"PUBLISHED","datePublished":"2022-07-06T17:30:13.000Z","dateUpdated":"2025-04-23T18:04:37.698Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-05-18T00:00:00.000Z"},"containers":{"cna":{"title":"Unauthenticated Remote Code Execution in Roxy-wi","descriptions":[{"lang":"en","value":"Roxy-wi is an open source web interface for managing Haproxy, Nginx, Apache and Keepalived servers. A vulnerability in Roxy-wi allows a remote, unauthenticated attacker to code execution by sending a specially crafted HTTP request to /app/options.py file. This affects Roxy-wi versions before 6.1.1.0. Users are advised to upgrade. There are no known workarounds for this issue."}],"affected":[{"vendor":"hap-wi","product":"roxy-wi","versions":[{"version":"< 6.1.1.0","status":"affected"}]}],"references":[{"url":"https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-mh86-878h-43c9","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":10,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-74","description":"CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-07-06T17:30:13.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-mh86-878h-43c9","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-31126","STATE":"PUBLIC","TITLE":"Unauthenticated Remote Code Execution in Roxy-wi"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"roxy-wi","version":{"version_data":[{"version_value":"< 6.1.1.0"}]}}]},"vendor_name":"hap-wi"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Roxy-wi is an open source web interface for managing Haproxy, Nginx, Apache and Keepalived servers. A vulnerability in Roxy-wi allows a remote, unauthenticated attacker to code execution by sending a specially crafted HTTP request to /app/options.py file. This affects Roxy-wi versions before 6.1.1.0. Users are advised to upgrade. There are no known workarounds for this issue."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":10,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')"}]}]},"references":{"reference_data":[{"name":"https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-mh86-878h-43c9","refsource":"CONFIRM","url":"https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-mh86-878h-43c9"}]},"source":{"advisory":"GHSA-mh86-878h-43c9","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-mh86-878h-43c9","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T07:11:39.586Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T15:48:58.232492Z","id":"CVE-2022-31126","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-23T18:04:37.698Z"}}]}}}