{"id":"CVE-2022-31020","state":"PUBLISHED","title":"Remote code execution in Indy's NODE_UPGRADE transaction","description":"Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded.","publishedAt":"2022-09-06T16:30:19.000Z","updatedAt":"2025-04-23T17:14:59.072Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["hyperledger indy-node"],"affected":[{"vendor":"hyperledger","product":"indy-node","versions":[{"version":"<= 1.12.4","status":"affected"}]}],"references":["https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p","https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","https://github.com/hyperledger/indy-node/releases/tag/v1.12.5"],"weaknesses":["CWE-287","CWE-20"],"ingestedAt":"2026-10-29T19:50:06.617Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/31xxx/CVE-2022-31020.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-31020","state":"PUBLISHED","datePublished":"2022-09-06T16:30:19.000Z","dateUpdated":"2025-04-23T17:14:59.072Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-05-18T00:00:00.000Z"},"containers":{"cna":{"title":"Remote code execution in Indy's NODE_UPGRADE transaction","descriptions":[{"lang":"en","value":"Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded."}],"affected":[{"vendor":"hyperledger","product":"indy-node","versions":[{"version":"<= 1.12.4","status":"affected"}]}],"references":[{"url":"https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","tags":["x_refsource_MISC"]},{"url":"https://github.com/hyperledger/indy-node/releases/tag/v1.12.5","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-287","description":"CWE-287: Improper Authentication","lang":"en","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-20","description":"CWE-20: Improper Input Validation","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-09-06T16:30:19.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-r6v9-p59m-gj2p","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-31020","STATE":"PUBLIC","TITLE":"Remote code execution in Indy's NODE_UPGRADE transaction"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"indy-node","version":{"version_data":[{"version_value":"<= 1.12.4"}]}}]},"vendor_name":"hyperledger"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In versions 1.12.4 and prior, the `pool-upgrade` request handler in Indy-Node allows an improperly authenticated attacker to remotely execute code on nodes within the network. The `pool-upgrade` request handler in Indy-Node 1.12.5 has been updated to properly authenticate pool-upgrade transactions before any processing is performed by the request handler. The transactions are further sanitized to prevent remote code execution. As a workaround, endorsers should not create DIDs for untrusted users. A vulnerable ledger should configure `auth_rules` to prevent new DIDs from being written to the ledger until the network can be upgraded."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-287: Improper Authentication"}]},{"description":[{"lang":"eng","value":"CWE-20: Improper Input Validation"}]}]},"references":{"reference_data":[{"name":"https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p","refsource":"CONFIRM","url":"https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p"},{"name":"https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","refsource":"MISC","url":"https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5"},{"name":"https://github.com/hyperledger/indy-node/releases/tag/v1.12.5","refsource":"MISC","url":"https://github.com/hyperledger/indy-node/releases/tag/v1.12.5"}]},"source":{"advisory":"GHSA-r6v9-p59m-gj2p","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/hyperledger/indy-node/security/advisories/GHSA-r6v9-p59m-gj2p","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/hyperledger/indy-node/commit/fe507474f77084faef4539101e2bbb4d508a97f5","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/hyperledger/indy-node/releases/tag/v1.12.5","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T07:03:40.339Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T15:49:58.564323Z","id":"CVE-2022-31020","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-23T17:14:59.072Z"}}]}}}