{"id":"CVE-2022-30688","state":"PUBLISHED","title":"needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to ","description":"needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.","publishedAt":"2022-05-17T18:58:09.000Z","updatedAt":"2025-11-03T21:46:15.566Z","severity":null,"assigner":"mitre","products":["n/a n/a"],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":["https://github.com/liske/needrestart/releases/tag/v3.6","https://github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30","https://lists.debian.org/debian-security-announce/2022/msg00105.html","https://www.openwall.com/lists/oss-security/2022/05/17/9","http://www.openwall.com/lists/oss-security/2022/05/17/9","https://www.debian.org/security/2022/dsa-5137","https://lists.debian.org/debian-lts-announce/2022/05/msg00024.html","http://seclists.org/fulldisclosure/2024/Nov/17","http://seclists.org/fulldisclosure/2024/Nov/15"],"weaknesses":[],"ingestedAt":"2026-10-29T19:50:04.052Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/30xxx/CVE-2022-30688.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-30688","state":"PUBLISHED","datePublished":"2022-05-17T18:58:09.000Z","dateUpdated":"2025-11-03T21:46:15.566Z","assignerShortName":"mitre","assignerOrgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateReserved":"2022-05-13T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files."}],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":[{"url":"https://github.com/liske/needrestart/releases/tag/v3.6","tags":["x_refsource_MISC"]},{"url":"https://github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30","tags":["x_refsource_MISC"]},{"url":"https://lists.debian.org/debian-security-announce/2022/msg00105.html","tags":["x_refsource_MISC"]},{"url":"https://www.openwall.com/lists/oss-security/2022/05/17/9","tags":["x_refsource_MISC"]},{"url":"http://www.openwall.com/lists/oss-security/2022/05/17/9","name":"[oss-security] 20220517 CVE-2022-30688: needrestart 0.8+ local privilege escalation","tags":["mailing-list","x_refsource_MLIST"]},{"url":"https://www.debian.org/security/2022/dsa-5137","name":"DSA-5137","tags":["vendor-advisory","x_refsource_DEBIAN"]},{"url":"https://lists.debian.org/debian-lts-announce/2022/05/msg00024.html","name":"[debian-lts-announce] 20220518 [SECURITY] [DLA 3013-1] needrestart security update","tags":["mailing-list","x_refsource_MLIST"]}],"problemTypes":[{"descriptions":[{"description":"n/a","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"mitre","dateUpdated":"2022-05-18T02:06:12.000Z","orgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"cve@mitre.org","ID":"CVE-2022-30688","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"n/a","version":{"version_data":[{"version_value":"n/a"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"n/a"}]}]},"references":{"reference_data":[{"name":"https://github.com/liske/needrestart/releases/tag/v3.6","refsource":"MISC","url":"https://github.com/liske/needrestart/releases/tag/v3.6"},{"name":"https://github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30","refsource":"MISC","url":"https://github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30"},{"name":"https://lists.debian.org/debian-security-announce/2022/msg00105.html","refsource":"MISC","url":"https://lists.debian.org/debian-security-announce/2022/msg00105.html"},{"name":"https://www.openwall.com/lists/oss-security/2022/05/17/9","refsource":"MISC","url":"https://www.openwall.com/lists/oss-security/2022/05/17/9"},{"name":"[oss-security] 20220517 CVE-2022-30688: needrestart 0.8+ local privilege escalation","refsource":"MLIST","url":"http://www.openwall.com/lists/oss-security/2022/05/17/9"},{"name":"DSA-5137","refsource":"DEBIAN","url":"https://www.debian.org/security/2022/dsa-5137"},{"name":"[debian-lts-announce] 20220518 [SECURITY] [DLA 3013-1] needrestart security update","refsource":"MLIST","url":"https://lists.debian.org/debian-lts-announce/2022/05/msg00024.html"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/liske/needrestart/releases/tag/v3.6","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://lists.debian.org/debian-security-announce/2022/msg00105.html","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://www.openwall.com/lists/oss-security/2022/05/17/9","tags":["x_refsource_MISC","x_transferred"]},{"url":"http://www.openwall.com/lists/oss-security/2022/05/17/9","name":"[oss-security] 20220517 CVE-2022-30688: needrestart 0.8+ local privilege escalation","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"https://www.debian.org/security/2022/dsa-5137","name":"DSA-5137","tags":["vendor-advisory","x_refsource_DEBIAN","x_transferred"]},{"url":"https://lists.debian.org/debian-lts-announce/2022/05/msg00024.html","name":"[debian-lts-announce] 20220518 [SECURITY] [DLA 3013-1] needrestart security update","tags":["mailing-list","x_refsource_MLIST","x_transferred"]},{"url":"http://seclists.org/fulldisclosure/2024/Nov/17"},{"url":"http://seclists.org/fulldisclosure/2024/Nov/15"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-03T21:46:15.566Z"}}]}}}