{"id":"CVE-2022-29444","state":"PUBLISHED","title":"WordPress Breeze plugin <= 2.0.2 - Plugin Settings Change leading to Cross-Site Scripting (XSS) vulnerability","description":"Plugin Settings Change leading to Cross-Site Scripting (XSS) vulnerability in Cloudways Breeze plugin <= 2.0.2 on WordPress allows users with a subscriber or higher user role to execute any of the wp_ajax_* actions in the class Breeze_Configuration which includes the ability to change any of the plugin's settings including CDN setting which could be further used for XSS attack.","publishedAt":"2022-05-02T19:03:32.539Z","updatedAt":"2026-04-28T16:07:42.199Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","source":"Patchstack"},"assigner":"Patchstack","products":["Cloudways Breeze (WordPress plugin)"],"affected":[{"vendor":"Cloudways","product":"Breeze (WordPress plugin)","versions":[{"version":"<= 2.0.2","status":"affected","lessThanOrEqual":"2.0.2","versionType":"custom"}]}],"references":["https://wordpress.org/plugins/breeze/#developers","https://patchstack.com/database/vulnerability/breeze/wordpress-breeze-plugin-2-0-2-plugin-settings-change-leading-to-cross-site-scripting-xss-vulnerability"],"weaknesses":["CWE-264","CWE-79"],"ingestedAt":"2026-10-29T19:49:57.813Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/29xxx/CVE-2022-29444.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-29444","state":"PUBLISHED","datePublished":"2022-05-02T19:03:32.539Z","dateUpdated":"2026-04-28T16:07:42.199Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2022-04-18T00:00:00.000Z"},"containers":{"cna":{"title":"WordPress Breeze plugin <= 2.0.2 - Plugin Settings Change leading to Cross-Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Plugin Settings Change leading to Cross-Site Scripting (XSS) vulnerability in Cloudways Breeze plugin <= 2.0.2 on WordPress allows users with a subscriber or higher user role to execute any of the wp_ajax_* actions in the class Breeze_Configuration which includes the ability to change any of the plugin's settings including CDN setting which could be further used for XSS attack."}],"affected":[{"vendor":"Cloudways","product":"Breeze (WordPress plugin)","versions":[{"version":"<= 2.0.2","status":"affected","lessThanOrEqual":"2.0.2","versionType":"custom"}]}],"references":[{"url":"https://wordpress.org/plugins/breeze/#developers","tags":["x_refsource_CONFIRM"]},{"url":"https://patchstack.com/database/vulnerability/breeze/wordpress-breeze-plugin-2-0-2-plugin-settings-change-leading-to-cross-site-scripting-xss-vulnerability","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":6.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-264","description":"CWE-264 Permissions, Privileges, and Access Controls","lang":"en","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:07:42.199Z"},"credits":[{"lang":"en","value":"Vulnerability discovered by Dave Jong (Patchstack)"}],"datePublic":"2022-05-02T00:00:00.000Z","solutions":[{"lang":"en","value":"Update to 2.0.3 or higher version."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"audit@patchstack.com","DATE_PUBLIC":"2022-05-02T13:12:00.000Z","ID":"CVE-2022-29444","STATE":"PUBLIC","TITLE":"WordPress Breeze plugin <= 2.0.2 - Plugin Settings Change leading to Cross-Site Scripting (XSS) vulnerability"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Breeze (WordPress plugin)","version":{"version_data":[{"version_affected":"<=","version_name":"<= 2.0.2","version_value":"2.0.2"}]}}]},"vendor_name":"Cloudways"}]}},"credit":[{"lang":"eng","value":"Vulnerability discovered by Dave Jong (Patchstack)"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Plugin Settings Change leading to Cross-Site Scripting (XSS) vulnerability in Cloudways Breeze plugin <= 2.0.2 on WordPress allows users with a subscriber or higher user role to execute any of the wp_ajax_* actions in the class Breeze_Configuration which includes the ability to change any of the plugin's settings including CDN setting which could be further used for XSS attack."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":6.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-264 Permissions, Privileges, and Access Controls"}]},{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wordpress.org/plugins/breeze/#developers","refsource":"CONFIRM","url":"https://wordpress.org/plugins/breeze/#developers"},{"name":"https://patchstack.com/database/vulnerability/breeze/wordpress-breeze-plugin-2-0-2-plugin-settings-change-leading-to-cross-site-scripting-xss-vulnerability","refsource":"CONFIRM","url":"https://patchstack.com/database/vulnerability/breeze/wordpress-breeze-plugin-2-0-2-plugin-settings-change-leading-to-cross-site-scripting-xss-vulnerability"}]},"solution":[{"lang":"en","value":"Update to 2.0.3 or higher version."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wordpress.org/plugins/breeze/#developers","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://patchstack.com/database/vulnerability/breeze/wordpress-breeze-plugin-2-0-2-plugin-settings-change-leading-to-cross-site-scripting-xss-vulnerability","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T06:26:04.876Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-20T19:30:40.905245Z","id":"CVE-2022-29444","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-20T20:23:47.562Z"}}]}}}