{"id":"CVE-2022-29428","state":"PUBLISHED","title":"WordPress WP Slider Plugin <= 1.4.5 - Cross-Site Scripting (XSS) vulnerability","description":"Cross-Site Scripting (XSS) vulnerability in Muneeb's WP Slider Plugin <= 1.4.5 at WordPress.","publishedAt":"2022-05-20T20:41:17.912Z","updatedAt":"2026-04-28T16:07:41.606Z","severity":{"score":4.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N","source":"Patchstack"},"assigner":"Patchstack","products":["Muneeb WP Slider Plugin"],"affected":[{"vendor":"Muneeb","product":"WP Slider Plugin","versions":[{"version":"<= 1.4.5","status":"affected","lessThanOrEqual":"1.4.5","versionType":"custom"}]}],"references":["https://wordpress.org/plugins/simple-slider-ssp/#developers","https://patchstack.com/database/vulnerability/simple-slider-ssp/wordpress-wp-slider-plugin-1-4-5-cross-site-scripting-xss-vulnerability"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:49:57.813Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/29xxx/CVE-2022-29428.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-29428","state":"PUBLISHED","datePublished":"2022-05-20T20:41:17.912Z","dateUpdated":"2026-04-28T16:07:41.606Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2022-04-18T00:00:00.000Z"},"containers":{"cna":{"title":"WordPress WP Slider Plugin <= 1.4.5 - Cross-Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Cross-Site Scripting (XSS) vulnerability in Muneeb's WP Slider Plugin <= 1.4.5 at WordPress."}],"affected":[{"vendor":"Muneeb","product":"WP Slider Plugin","versions":[{"version":"<= 1.4.5","status":"affected","lessThanOrEqual":"1.4.5","versionType":"custom"}]}],"references":[{"url":"https://wordpress.org/plugins/simple-slider-ssp/#developers","tags":["x_refsource_CONFIRM"]},{"url":"https://patchstack.com/database/vulnerability/simple-slider-ssp/wordpress-wp-slider-plugin-1-4-5-cross-site-scripting-xss-vulnerability","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.1,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:07:41.606Z"},"credits":[{"lang":"en","value":"Vulnerability discovered by Ngo Van Thien (Patchstack Alliance)"}],"datePublic":"2022-05-04T00:00:00.000Z","solutions":[{"lang":"en","value":"Deactivate and delete. No patched version is available. No reply from the vendor. Last time was updated in 2016."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"audit@patchstack.com","DATE_PUBLIC":"2022-05-04T12:51:00.000Z","ID":"CVE-2022-29428","STATE":"PUBLIC","TITLE":"WordPress WP Slider Plugin <= 1.4.5 - Cross-Site Scripting (XSS) vulnerability"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP Slider Plugin","version":{"version_data":[{"version_affected":"<=","version_name":"<= 1.4.5","version_value":"1.4.5"}]}}]},"vendor_name":"Muneeb"}]}},"credit":[{"lang":"eng","value":"Vulnerability discovered by Ngo Van Thien (Patchstack Alliance)"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Cross-Site Scripting (XSS) vulnerability in Muneeb's WP Slider Plugin <= 1.4.5 at WordPress."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.1,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wordpress.org/plugins/simple-slider-ssp/#developers","refsource":"CONFIRM","url":"https://wordpress.org/plugins/simple-slider-ssp/#developers"},{"name":"https://patchstack.com/database/vulnerability/simple-slider-ssp/wordpress-wp-slider-plugin-1-4-5-cross-site-scripting-xss-vulnerability","refsource":"CONFIRM","url":"https://patchstack.com/database/vulnerability/simple-slider-ssp/wordpress-wp-slider-plugin-1-4-5-cross-site-scripting-xss-vulnerability"}]},"solution":[{"lang":"en","value":"Deactivate and delete. No patched version is available. No reply from the vendor. Last time was updated in 2016."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wordpress.org/plugins/simple-slider-ssp/#developers","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://patchstack.com/database/vulnerability/simple-slider-ssp/wordpress-wp-slider-plugin-1-4-5-cross-site-scripting-xss-vulnerability","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T06:17:55.276Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-20T19:29:48.026977Z","id":"CVE-2022-29428","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-20T20:21:04.332Z"}}]}}}