{"id":"CVE-2022-2597","state":"PUBLISHED","title":"Visual Portfolio < 2.19.0 - Contributor+ CSS Injection","description":"The Visual Portfolio, Photo Gallery & Post Grid WordPress plugin before 2.19.0 does not have proper authorisation checks in some of its REST endpoints, allowing users with a role as low as contributor to call them and inject arbitrary CSS in arbitrary saved layouts","publishedAt":"2022-09-05T12:35:21.000Z","updatedAt":"2024-08-03T00:46:03.062Z","severity":null,"assigner":"WPScan","products":["Unknown Visual Portfolio, Photo Gallery & Post Grid"],"affected":[{"vendor":"Unknown","product":"Visual Portfolio, Photo Gallery & Post Grid","versions":[{"version":"2.19.0","status":"affected","lessThan":"2.19.0","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/3ffcee7c-1e03-448c-8006-a9405658cdb7"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T19:50:01.354Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/2xxx/CVE-2022-2597.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-2597","state":"PUBLISHED","datePublished":"2022-09-05T12:35:21.000Z","dateUpdated":"2024-08-03T00:46:03.062Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-08-01T00:00:00.000Z"},"containers":{"cna":{"title":"Visual Portfolio < 2.19.0 - Contributor+ CSS Injection","descriptions":[{"lang":"en","value":"The Visual Portfolio, Photo Gallery & Post Grid WordPress plugin before 2.19.0 does not have proper authorisation checks in some of its REST endpoints, allowing users with a role as low as contributor to call them and inject arbitrary CSS in arbitrary saved layouts"}],"affected":[{"vendor":"Unknown","product":"Visual Portfolio, Photo Gallery & Post Grid","versions":[{"version":"2.19.0","status":"affected","lessThan":"2.19.0","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/3ffcee7c-1e03-448c-8006-a9405658cdb7","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","description":"CWE-863 Incorrect Authorization","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-09-05T12:35:21.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Krzysztof Zając"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-2597","STATE":"PUBLIC","TITLE":"Visual Portfolio < 2.19.0 - Contributor+ CSS Injection"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Visual Portfolio, Photo Gallery & Post Grid","version":{"version_data":[{"version_affected":"<","version_name":"2.19.0","version_value":"2.19.0"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Krzysztof Zając"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Visual Portfolio, Photo Gallery & Post Grid WordPress plugin before 2.19.0 does not have proper authorisation checks in some of its REST endpoints, allowing users with a role as low as contributor to call them and inject arbitrary CSS in arbitrary saved layouts"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-863 Incorrect Authorization"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/3ffcee7c-1e03-448c-8006-a9405658cdb7","refsource":"MISC","url":"https://wpscan.com/vulnerability/3ffcee7c-1e03-448c-8006-a9405658cdb7"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/3ffcee7c-1e03-448c-8006-a9405658cdb7","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:46:03.062Z"}}]}}}