{"id":"CVE-2022-25812","state":"PUBLISHED","title":"Transposh WordPress Translation < 1.0.8 - Admin+ RCE","description":"The Transposh WordPress Translation WordPress plugin before 1.0.8 does not validate its debug settings, which could allow allowing high privilege users such as admin to perform RCE","publishedAt":"2022-08-22T14:59:06.000Z","updatedAt":"2024-08-03T04:49:43.741Z","severity":null,"assigner":"WPScan","products":["Unknown Transposh WordPress Translation"],"affected":[{"vendor":"Unknown","product":"Transposh WordPress Translation","versions":[{"version":"1.0.8","status":"affected","lessThan":"1.0.8","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/1f6bd346-4743-44b8-86d7-4fbe09bad657"],"weaknesses":["CWE-94"],"ingestedAt":"2026-10-29T19:49:46.971Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/25xxx/CVE-2022-25812.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-25812","state":"PUBLISHED","datePublished":"2022-08-22T14:59:06.000Z","dateUpdated":"2024-08-03T04:49:43.741Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-02-23T00:00:00.000Z"},"containers":{"cna":{"title":"Transposh WordPress Translation < 1.0.8 - Admin+ RCE","descriptions":[{"lang":"en","value":"The Transposh WordPress Translation WordPress plugin before 1.0.8 does not validate its debug settings, which could allow allowing high privilege users such as admin to perform RCE"}],"affected":[{"vendor":"Unknown","product":"Transposh WordPress Translation","versions":[{"version":"1.0.8","status":"affected","lessThan":"1.0.8","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/1f6bd346-4743-44b8-86d7-4fbe09bad657","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-94","description":"CWE-94 Improper Control of Generation of Code ('Code Injection')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-08-22T14:59:06.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Julien Ahrens"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-25812","STATE":"PUBLIC","TITLE":"Transposh WordPress Translation < 1.0.8 - Admin+ RCE"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Transposh WordPress Translation","version":{"version_data":[{"version_affected":"<","version_name":"1.0.8","version_value":"1.0.8"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Julien Ahrens"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Transposh WordPress Translation WordPress plugin before 1.0.8 does not validate its debug settings, which could allow allowing high privilege users such as admin to perform RCE"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-94 Improper Control of Generation of Code ('Code Injection')"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/1f6bd346-4743-44b8-86d7-4fbe09bad657","refsource":"MISC","url":"https://wpscan.com/vulnerability/1f6bd346-4743-44b8-86d7-4fbe09bad657"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/1f6bd346-4743-44b8-86d7-4fbe09bad657","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T04:49:43.741Z"}}]}}}