{"id":"CVE-2022-25768","state":"PUBLISHED","title":"Improper Access Control in UI upgrade process","description":"The logic in place to facilitate the update process via the user interface lacks access control to verify if permission exists to perform the tasks. Prior to this patch being applied it might be possible for an attacker to access the Mautic version number or to execute parts of the upgrade process without permission. As upgrading in the user interface is deprecated, this functionality is no longer required.","publishedAt":"2024-09-18T20:55:53.187Z","updatedAt":"2024-09-19T15:42:44.517Z","severity":{"score":7,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H","source":"Mautic"},"assigner":"Mautic","products":["Mautic Mautic"],"affected":[{"vendor":"Mautic","product":"Mautic","packageName":"mautic/core","defaultStatus":"unaffected","versions":[{"version":">= 1.1.3","status":"affected","lessThan":"< 4.4.13","versionType":"semver"},{"version":">= 5.0.0","status":"affected","lessThan":"< 5.1.1","versionType":"semver"}],"collectionURL":"https://packagist.org","repo":"https://github.com/mautic/mautic"}],"references":["https://github.com/mautic/mautic/security/advisories/GHSA-x3jx-5w6m-q2fc"],"weaknesses":["CWE-287"],"ingestedAt":"2026-10-29T19:49:46.971Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/25xxx/CVE-2022-25768.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-25768","state":"PUBLISHED","datePublished":"2024-09-18T20:55:53.187Z","dateUpdated":"2024-09-19T15:42:44.517Z","assignerShortName":"Mautic","assignerOrgId":"4e531c38-7a33-45d3-98dd-d909c0d8852e","dateReserved":"2022-02-22T20:17:36.803Z"},"containers":{"cna":{"title":"Improper Access Control in UI upgrade process","descriptions":[{"lang":"en","value":"The logic in place to facilitate the update process via the user interface lacks access control to verify if permission exists to perform the tasks. Prior to this patch being applied it might be possible for an attacker to access the Mautic version number or to execute parts of the upgrade process without permission. As upgrading in the user interface is deprecated, this functionality is no longer required."}],"affected":[{"vendor":"Mautic","product":"Mautic","packageName":"mautic/core","defaultStatus":"unaffected","versions":[{"version":">= 1.1.3","status":"affected","lessThan":"< 4.4.13","versionType":"semver"},{"version":">= 5.0.0","status":"affected","lessThan":"< 5.1.1","versionType":"semver"}],"collectionURL":"https://packagist.org","repo":"https://github.com/mautic/mautic"}],"references":[{"url":"https://github.com/mautic/mautic/security/advisories/GHSA-x3jx-5w6m-q2fc"}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":7,"baseSeverity":"HIGH","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H","version":"3.1"},"format":"CVSS","scenarios":[{"lang":"en","value":"GENERAL"}]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-287","description":"CWE-287 Improper Authentication","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Mautic","orgId":"4e531c38-7a33-45d3-98dd-d909c0d8852e","dateUpdated":"2024-09-18T20:55:53.187Z"},"credits":[{"lang":"en","type":"reporter","value":"Mattias Michaux"},{"lang":"en","type":"remediation reviewer","value":"Patryk Gruszka"},{"lang":"en","type":"remediation reviewer","value":"John Linhart"}],"datePublic":"2024-09-18T17:43:00.000Z","impacts":[{"capecId":"CAPEC-1","descriptions":[{"lang":"en","value":"CAPEC-1 Accessing Functionality Not Properly Constrained by ACLs"}]}],"solutions":[{"lang":"en","supportingMedia":[{"base64":false,"type":"text/html","value":"Update to 4.4.13 or 5.1.1 or higher."}],"value":"Update to 4.4.13 or 5.1.1 or higher."}],"source":{"advisory":"GHSA-x3jx-5w6m-q2fc","discovery":"USER"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-09-19T15:42:37.075391Z","id":"CVE-2022-25768","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-09-19T15:42:44.517Z"}}]}}}