{"id":"CVE-2022-24889","state":"PUBLISHED","title":"Insufficient Verification of Data Authenticity in Nextcloud Server","description":"Nextcloud Server is the file server software for Nextcloud, a self-hosted productivity platform. Prior to versions 21.0.8, 22.2.4, and 23.0.1, it is possible to trick administrators into enabling \"recommended\" apps for the Nextcloud server that they do not need, thus expanding their attack surface unnecessarily. This issue is fixed in versions 21.0.8 , 22.2.4, and 23.0.1.","publishedAt":"2022-04-27T14:35:13.000Z","updatedAt":"2025-04-22T18:02:55.232Z","severity":{"score":2.4,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["nextcloud security-advisories"],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 21.0.8","status":"affected"},{"version":"< 22.2.4","status":"affected"},{"version":"< 23.0.1","status":"affected"}]}],"references":["https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6","https://github.com/nextcloud/server/pull/30615","https://hackerone.com/reports/1403614","https://security.gentoo.org/glsa/202208-17"],"weaknesses":["CWE-345"],"ingestedAt":"2026-10-29T19:49:43.915Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/24xxx/CVE-2022-24889.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-24889","state":"PUBLISHED","datePublished":"2022-04-27T14:35:13.000Z","dateUpdated":"2025-04-22T18:02:55.232Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-02-10T00:00:00.000Z"},"containers":{"cna":{"title":"Insufficient Verification of Data Authenticity in Nextcloud Server","descriptions":[{"lang":"en","value":"Nextcloud Server is the file server software for Nextcloud, a self-hosted productivity platform. Prior to versions 21.0.8, 22.2.4, and 23.0.1, it is possible to trick administrators into enabling \"recommended\" apps for the Nextcloud server that they do not need, thus expanding their attack surface unnecessarily. This issue is fixed in versions 21.0.8 , 22.2.4, and 23.0.1."}],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 21.0.8","status":"affected"},{"version":"< 22.2.4","status":"affected"},{"version":"< 23.0.1","status":"affected"}]}],"references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/nextcloud/server/pull/30615","tags":["x_refsource_MISC"]},{"url":"https://hackerone.com/reports/1403614","tags":["x_refsource_MISC"]},{"url":"https://security.gentoo.org/glsa/202208-17","name":"GLSA-202208-17","tags":["vendor-advisory","x_refsource_GENTOO"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":2.4,"baseSeverity":"LOW","confidentialityImpact":"NONE","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-345","description":"CWE-345: Insufficient Verification of Data Authenticity","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-08-11T00:07:42.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-5vw6-6prg-gvw6","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-24889","STATE":"PUBLIC","TITLE":"Insufficient Verification of Data Authenticity in Nextcloud Server"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"security-advisories","version":{"version_data":[{"version_value":"< 21.0.8"},{"version_value":"< 22.2.4"},{"version_value":"< 23.0.1"}]}}]},"vendor_name":"nextcloud"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Nextcloud Server is the file server software for Nextcloud, a self-hosted productivity platform. Prior to versions 21.0.8, 22.2.4, and 23.0.1, it is possible to trick administrators into enabling \"recommended\" apps for the Nextcloud server that they do not need, thus expanding their attack surface unnecessarily. This issue is fixed in versions 21.0.8 , 22.2.4, and 23.0.1."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":2.4,"baseSeverity":"LOW","confidentialityImpact":"NONE","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-345: Insufficient Verification of Data Authenticity"}]}]},"references":{"reference_data":[{"name":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6","refsource":"CONFIRM","url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6"},{"name":"https://github.com/nextcloud/server/pull/30615","refsource":"MISC","url":"https://github.com/nextcloud/server/pull/30615"},{"name":"https://hackerone.com/reports/1403614","refsource":"MISC","url":"https://hackerone.com/reports/1403614"},{"name":"GLSA-202208-17","refsource":"GENTOO","url":"https://security.gentoo.org/glsa/202208-17"}]},"source":{"advisory":"GHSA-5vw6-6prg-gvw6","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5vw6-6prg-gvw6","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/nextcloud/server/pull/30615","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://hackerone.com/reports/1403614","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://security.gentoo.org/glsa/202208-17","name":"GLSA-202208-17","tags":["vendor-advisory","x_refsource_GENTOO","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T04:29:01.495Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-22T15:48:24.886031Z","id":"CVE-2022-24889","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-22T18:02:55.232Z"}}]}}}