{"id":"CVE-2022-24856","state":"PUBLISHED","title":"Server-Side Request Forgery in FlyteConsole","description":"FlyteConsole is the web user interface for the Flyte platform. FlyteConsole prior to version 0.52.0 is vulnerable to server-side request forgery (SSRF) when FlyteConsole is open to the general internet. An attacker can exploit any user of a vulnerable instance to access the internal metadata server or other unauthenticated URLs. Passing of headers to an unauthorized actor may occur. The patch for this issue deletes the entire `cors_proxy`, as this is not required for console anymore. A patch is available in FlyteConsole version 0.52.0. Disable FlyteConsole availability on the internet as a workaround.","publishedAt":"2022-05-17T15:25:11.000Z","updatedAt":"2025-04-23T18:25:36.919Z","severity":{"score":9.1,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["flyteorg flyteconsole"],"affected":[{"vendor":"flyteorg","product":"flyteconsole","versions":[{"version":"< 0.52.0","status":"affected"}]}],"references":["https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9","https://github.com/flyteorg/flyteconsole/pull/389","https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709","https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0"],"weaknesses":["CWE-918"],"ingestedAt":"2026-10-29T19:49:43.915Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/24xxx/CVE-2022-24856.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-24856","state":"PUBLISHED","datePublished":"2022-05-17T15:25:11.000Z","dateUpdated":"2025-04-23T18:25:36.919Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-02-10T00:00:00.000Z"},"containers":{"cna":{"title":"Server-Side Request Forgery in FlyteConsole","descriptions":[{"lang":"en","value":"FlyteConsole is the web user interface for the Flyte platform. FlyteConsole prior to version 0.52.0 is vulnerable to server-side request forgery (SSRF) when FlyteConsole is open to the general internet. An attacker can exploit any user of a vulnerable instance to access the internal metadata server or other unauthenticated URLs. Passing of headers to an unauthorized actor may occur. The patch for this issue deletes the entire `cors_proxy`, as this is not required for console anymore. A patch is available in FlyteConsole version 0.52.0. Disable FlyteConsole availability on the internet as a workaround."}],"affected":[{"vendor":"flyteorg","product":"flyteconsole","versions":[{"version":"< 0.52.0","status":"affected"}]}],"references":[{"url":"https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/flyteorg/flyteconsole/pull/389","tags":["x_refsource_MISC"]},{"url":"https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709","tags":["x_refsource_MISC"]},{"url":"https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":9.1,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-918","description":"CWE-918: Server-Side Request Forgery (SSRF)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-05-17T15:25:11.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-www6-hf2v-v9m9","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-24856","STATE":"PUBLIC","TITLE":"Server-Side Request Forgery in FlyteConsole"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"flyteconsole","version":{"version_data":[{"version_value":"< 0.52.0"}]}}]},"vendor_name":"flyteorg"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"FlyteConsole is the web user interface for the Flyte platform. FlyteConsole prior to version 0.52.0 is vulnerable to server-side request forgery (SSRF) when FlyteConsole is open to the general internet. An attacker can exploit any user of a vulnerable instance to access the internal metadata server or other unauthenticated URLs. Passing of headers to an unauthorized actor may occur. The patch for this issue deletes the entire `cors_proxy`, as this is not required for console anymore. A patch is available in FlyteConsole version 0.52.0. Disable FlyteConsole availability on the internet as a workaround."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":9.1,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-918: Server-Side Request Forgery (SSRF)"}]}]},"references":{"reference_data":[{"name":"https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9","refsource":"CONFIRM","url":"https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9"},{"name":"https://github.com/flyteorg/flyteconsole/pull/389","refsource":"MISC","url":"https://github.com/flyteorg/flyteconsole/pull/389"},{"name":"https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709","refsource":"MISC","url":"https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709"},{"name":"https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0","refsource":"MISC","url":"https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0"}]},"source":{"advisory":"GHSA-www6-hf2v-v9m9","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/flyteorg/flyteconsole/security/advisories/GHSA-www6-hf2v-v9m9","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/flyteorg/flyteconsole/pull/389","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/flyteorg/flyteconsole/commit/05b88ed2d2ecdb5d8a8404efea25414e57189709","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/flyteorg/flyteconsole/releases/tag/v0.52.0","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T04:20:50.529Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T15:49:43.690059Z","id":"CVE-2022-24856","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-23T18:25:36.919Z"}}]}}}