{"id":"CVE-2022-2461","state":"PUBLISHED","title":"Transposh WordPress Translation <= 1.0.9.6 - Unauthorized Settings Change","description":"The Transposh WordPress Translation plugin for WordPress is vulnerable to unauthorized setting changes by unauthenticated users in versions up to, and including, 1.0.9.6. This is due to insufficient permissions checking on the 'tp_translation' AJAX action and default settings which makes it possible for unauthenticated attackers to influence the data shown on the site.","publishedAt":"2022-09-06T17:18:58.000Z","updatedAt":"2026-04-08T16:41:36.744Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["oferwald Transposh WordPress Translation"],"affected":[{"vendor":"oferwald","product":"Transposh WordPress Translation","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.9.6","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/223373fc-9d78-47f0-b283-109f8e00b802?source=cve","https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2461","https://www.rcesecurity.com/2022/07/WordPress-Transposh-Exploiting-a-Blind-SQL-Injection-via-XSS/","https://plugins.trac.wordpress.org/browser/transposh-translation-filter-for-wordpress/trunk/transposh.php?rev=2682425#L1989","https://packetstormsecurity.com/files/167870/wptransposh107-auth.txt","https://www.exploitalert.com/view-details.html?id=38891"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T19:50:01.354Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/2xxx/CVE-2022-2461.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-2461","state":"PUBLISHED","datePublished":"2022-09-06T17:18:58.000Z","dateUpdated":"2026-04-08T16:41:36.744Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2022-07-18T00:00:00.000Z"},"containers":{"cna":{"title":"Transposh WordPress Translation <= 1.0.9.6 - Unauthorized Settings Change","descriptions":[{"lang":"en","value":"The Transposh WordPress Translation plugin for WordPress is vulnerable to unauthorized setting changes by unauthenticated users in versions up to, and including, 1.0.9.6. This is due to insufficient permissions checking on the 'tp_translation' AJAX action and default settings which makes it possible for unauthenticated attackers to influence the data shown on the site."}],"affected":[{"vendor":"oferwald","product":"Transposh WordPress Translation","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.9.6","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/223373fc-9d78-47f0-b283-109f8e00b802?source=cve"},{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2461"},{"url":"https://www.rcesecurity.com/2022/07/WordPress-Transposh-Exploiting-a-Blind-SQL-Injection-via-XSS/"},{"url":"https://plugins.trac.wordpress.org/browser/transposh-translation-filter-for-wordpress/trunk/transposh.php?rev=2682425#L1989"},{"url":"https://packetstormsecurity.com/files/167870/wptransposh107-auth.txt"},{"url":"https://www.exploitalert.com/view-details.html?id=38891"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","baseScore":5.3,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","lang":"en","description":"CWE-862 Missing Authorization","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:41:36.744Z"},"credits":[{"lang":"en","type":"finder","value":"Julien Ahrens"}],"timeline":[{"time":"2022-07-18T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/223373fc-9d78-47f0-b283-109f8e00b802?source=cve","tags":["x_transferred"]},{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2461","tags":["x_transferred"]},{"url":"https://www.rcesecurity.com/2022/07/WordPress-Transposh-Exploiting-a-Blind-SQL-Injection-via-XSS/","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/transposh-translation-filter-for-wordpress/trunk/transposh.php?rev=2682425#L1989","tags":["x_transferred"]},{"url":"https://packetstormsecurity.com/files/167870/wptransposh107-auth.txt","tags":["x_transferred"]},{"url":"https://www.exploitalert.com/view-details.html?id=38891","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:39:07.801Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T13:17:43.818829Z","id":"CVE-2022-2461","options":[{"Exploitation":"poc"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","type":"CWE","lang":"en","description":"CWE-862 Missing Authorization"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-05T16:18:40.559Z"}}]}}}