{"id":"CVE-2022-24299","state":"PUBLISHED","title":"Improper input validation vulnerability in pfSense CE and pfSense Plus (pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01) allows a remo","description":"Improper input validation vulnerability in pfSense CE and pfSense Plus (pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01) allows a remote attacker with the privilege to change OpenVPN client or server settings to execute an arbitrary command.","publishedAt":"2022-03-31T07:21:07.000Z","updatedAt":"2024-08-03T04:07:02.366Z","severity":null,"assigner":"jpcert","products":["pfSense pfSense CE and pfSense Plus"],"affected":[{"vendor":"pfSense","product":"pfSense CE and pfSense Plus","versions":[{"version":"pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01","status":"affected"}]}],"references":["https://jvn.jp/en/jp/JVN87751554/index.html","https://docs.netgate.com/downloads/pfSense-SA-22_03.webgui.asc"],"weaknesses":[],"ingestedAt":"2026-10-29T19:49:43.915Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/24xxx/CVE-2022-24299.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-24299","state":"PUBLISHED","datePublished":"2022-03-31T07:21:07.000Z","dateUpdated":"2024-08-03T04:07:02.366Z","assignerShortName":"jpcert","assignerOrgId":"ede6fdc4-6654-4307-a26d-3331c018e2ce","dateReserved":"2022-03-06T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"Improper input validation vulnerability in pfSense CE and pfSense Plus (pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01) allows a remote attacker with the privilege to change OpenVPN client or server settings to execute an arbitrary command."}],"affected":[{"vendor":"pfSense","product":"pfSense CE and pfSense Plus","versions":[{"version":"pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01","status":"affected"}]}],"references":[{"url":"https://jvn.jp/en/jp/JVN87751554/index.html","tags":["x_refsource_MISC"]},{"url":"https://docs.netgate.com/downloads/pfSense-SA-22_03.webgui.asc","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"description":"Improper Input Validation","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"jpcert","dateUpdated":"2022-03-31T07:21:07.000Z","orgId":"ede6fdc4-6654-4307-a26d-3331c018e2ce"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"vultures@jpcert.or.jp","ID":"CVE-2022-24299","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"pfSense CE and pfSense Plus","version":{"version_data":[{"version_value":"pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01"}]}}]},"vendor_name":"pfSense"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Improper input validation vulnerability in pfSense CE and pfSense Plus (pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01) allows a remote attacker with the privilege to change OpenVPN client or server settings to execute an arbitrary command."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Improper Input Validation"}]}]},"references":{"reference_data":[{"name":"https://jvn.jp/en/jp/JVN87751554/index.html","refsource":"MISC","url":"https://jvn.jp/en/jp/JVN87751554/index.html"},{"name":"https://docs.netgate.com/downloads/pfSense-SA-22_03.webgui.asc","refsource":"MISC","url":"https://docs.netgate.com/downloads/pfSense-SA-22_03.webgui.asc"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://jvn.jp/en/jp/JVN87751554/index.html","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://docs.netgate.com/downloads/pfSense-SA-22_03.webgui.asc","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T04:07:02.366Z"}}]}}}