{"id":"CVE-2022-23993","state":"PUBLISHED","title":"/usr/local/www/pkg.php in pfSense CE before 2.6.0 and pfSense Plus before 22.01 uses $_REQUEST['pkg_filter'] in a PHP echo call, causing XSS.","description":"/usr/local/www/pkg.php in pfSense CE before 2.6.0 and pfSense Plus before 22.01 uses $_REQUEST['pkg_filter'] in a PHP echo call, causing XSS.","publishedAt":"2022-01-26T18:22:26.000Z","updatedAt":"2024-08-03T03:59:23.256Z","severity":null,"assigner":"mitre","products":["n/a n/a"],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":["https://github.com/pfsense/pfsense/commit/5d82cce0d615a76b738798577a28a15803e59aeb","https://docs.netgate.com/downloads/pfSense-SA-22_04.webgui.asc"],"weaknesses":[],"ingestedAt":"2026-10-29T19:49:40.939Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/23xxx/CVE-2022-23993.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-23993","state":"PUBLISHED","datePublished":"2022-01-26T18:22:26.000Z","dateUpdated":"2024-08-03T03:59:23.256Z","assignerShortName":"mitre","assignerOrgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca","dateReserved":"2022-01-26T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"/usr/local/www/pkg.php in pfSense CE before 2.6.0 and pfSense Plus before 22.01 uses $_REQUEST['pkg_filter'] in a PHP echo call, causing XSS."}],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":[{"url":"https://github.com/pfsense/pfsense/commit/5d82cce0d615a76b738798577a28a15803e59aeb","tags":["x_refsource_MISC"]},{"url":"https://docs.netgate.com/downloads/pfSense-SA-22_04.webgui.asc","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"description":"n/a","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"mitre","dateUpdated":"2022-03-06T20:20:57.000Z","orgId":"8254265b-2729-46b6-b9e3-3dfca2d5bfca"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"cve@mitre.org","ID":"CVE-2022-23993","STATE":"PUBLIC"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"n/a","version":{"version_data":[{"version_value":"n/a"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"/usr/local/www/pkg.php in pfSense CE before 2.6.0 and pfSense Plus before 22.01 uses $_REQUEST['pkg_filter'] in a PHP echo call, causing XSS."}]},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"n/a"}]}]},"references":{"reference_data":[{"name":"https://github.com/pfsense/pfsense/commit/5d82cce0d615a76b738798577a28a15803e59aeb","refsource":"MISC","url":"https://github.com/pfsense/pfsense/commit/5d82cce0d615a76b738798577a28a15803e59aeb"},{"name":"https://docs.netgate.com/downloads/pfSense-SA-22_04.webgui.asc","refsource":"MISC","url":"https://docs.netgate.com/downloads/pfSense-SA-22_04.webgui.asc"}]}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/pfsense/pfsense/commit/5d82cce0d615a76b738798577a28a15803e59aeb","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://docs.netgate.com/downloads/pfSense-SA-22_04.webgui.asc","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T03:59:23.256Z"}}]}}}