{"id":"CVE-2022-23646","state":"PUBLISHED","title":"Improper CSP in Image Optimization API for Next.js","description":"Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default.","publishedAt":"2022-02-17T20:35:12.000Z","updatedAt":"2025-04-23T19:02:50.028Z","severity":{"score":5.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["vercel next.js"],"affected":[{"vendor":"vercel","product":"next.js","versions":[{"version":">= 10.0.0, < 12.1.0","status":"affected"}]}],"references":["https://github.com/vercel/next.js/security/advisories/GHSA-fmvm-x8mv-47mj","https://github.com/vercel/next.js/pull/34075","https://github.com/vercel/next.js/releases/tag/v12.1.0"],"weaknesses":["CWE-451"],"ingestedAt":"2026-10-29T19:49:40.939Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/23xxx/CVE-2022-23646.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-23646","state":"PUBLISHED","datePublished":"2022-02-17T20:35:12.000Z","dateUpdated":"2025-04-23T19:02:50.028Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2022-01-19T00:00:00.000Z"},"containers":{"cna":{"title":"Improper CSP in Image Optimization API for Next.js","descriptions":[{"lang":"en","value":"Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default."}],"affected":[{"vendor":"vercel","product":"next.js","versions":[{"version":">= 10.0.0, < 12.1.0","status":"affected"}]}],"references":[{"url":"https://github.com/vercel/next.js/security/advisories/GHSA-fmvm-x8mv-47mj","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/vercel/next.js/pull/34075","tags":["x_refsource_MISC"]},{"url":"https://github.com/vercel/next.js/releases/tag/v12.1.0","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.9,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-451","description":"CWE-451: User Interface (UI) Misrepresentation of Critical Information","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-02-17T20:35:12.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-fmvm-x8mv-47mj","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-23646","STATE":"PUBLIC","TITLE":"Improper CSP in Image Optimization API for Next.js"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"next.js","version":{"version_data":[{"version_value":">= 10.0.0, < 12.1.0"}]}}]},"vendor_name":"vercel"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Next.js is a React framework. Starting with version 10.0.0 and prior to version 12.1.0, Next.js is vulnerable to User Interface (UI) Misrepresentation of Critical Information. In order to be affected, the `next.config.js` file must have an `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default, the instance is not affected. Version 12.1.0 contains a patch for this issue. As a workaround, change `next.config.js` to use a different `loader configuration` other than the default."}]},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.9,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-451: User Interface (UI) Misrepresentation of Critical Information"}]}]},"references":{"reference_data":[{"name":"https://github.com/vercel/next.js/security/advisories/GHSA-fmvm-x8mv-47mj","refsource":"CONFIRM","url":"https://github.com/vercel/next.js/security/advisories/GHSA-fmvm-x8mv-47mj"},{"name":"https://github.com/vercel/next.js/pull/34075","refsource":"MISC","url":"https://github.com/vercel/next.js/pull/34075"},{"name":"https://github.com/vercel/next.js/releases/tag/v12.1.0","refsource":"MISC","url":"https://github.com/vercel/next.js/releases/tag/v12.1.0"}]},"source":{"advisory":"GHSA-fmvm-x8mv-47mj","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/vercel/next.js/security/advisories/GHSA-fmvm-x8mv-47mj","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/vercel/next.js/pull/34075","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/vercel/next.js/releases/tag/v12.1.0","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T03:51:45.557Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T14:10:23.654047Z","id":"CVE-2022-23646","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-23T19:02:50.028Z"}}]}}}