{"id":"CVE-2022-23057","state":"PUBLISHED","title":"ERPNext - Stored XSS in My Profile","description":"In ERPNext, versions v12.0.9--v13.0.3 are vulnerable to Stored Cross-Site-Scripting (XSS), due to user input not being validated properly. A low privileged attacker could inject arbitrary code into input fields when editing his profile.","publishedAt":"2022-06-22T07:25:11.161Z","updatedAt":"2024-09-16T17:14:26.886Z","severity":null,"assigner":"Mend","products":["frappe frappe"],"affected":[{"vendor":"frappe","product":"frappe","versions":[{"version":"v12.0.9","status":"affected","lessThan":"unspecified","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"v13.0.3","versionType":"custom"}]}],"references":["https://www.mend.io/vulnerability-database/CVE-2022-23057","https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:49:40.939Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/23xxx/CVE-2022-23057.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-23057","state":"PUBLISHED","datePublished":"2022-06-22T07:25:11.161Z","dateUpdated":"2024-09-16T17:14:26.886Z","assignerShortName":"Mend","assignerOrgId":"478c68dd-22c1-4a41-97cd-654224dfacff","dateReserved":"2022-01-10T00:00:00.000Z"},"containers":{"cna":{"title":"ERPNext - Stored XSS in My Profile","descriptions":[{"lang":"en","value":"In ERPNext, versions v12.0.9--v13.0.3 are vulnerable to Stored Cross-Site-Scripting (XSS), due to user input not being validated properly. A low privileged attacker could inject arbitrary code into input fields when editing his profile."}],"affected":[{"vendor":"frappe","product":"frappe","versions":[{"version":"v12.0.9","status":"affected","lessThan":"unspecified","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"v13.0.3","versionType":"custom"}]}],"references":[{"url":"https://www.mend.io/vulnerability-database/CVE-2022-23057","tags":["x_refsource_MISC"]},{"url":"https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7","tags":["x_refsource_MISC"]}],"metrics":[{"other":{"content":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":3.1},"type":"unknown"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Mend","dateUpdated":"2022-06-22T07:25:11.000Z","orgId":"478c68dd-22c1-4a41-97cd-654224dfacff"},"credits":[{"lang":"en","value":"Mend Vulnerability Research Team (MVR)"}],"datePublic":"2022-05-18T00:00:00.000Z","solutions":[{"lang":"en","value":"Update version to v13.1.0 or later"}],"source":{"advisory":"https://www.mend.io/vulnerability-database/","discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"vulnerabilitylab@whitesourcesoftware.com","DATE_PUBLIC":"May 18, 2022, 12:00:00 AM","ID":"CVE-2022-23057","STATE":"PUBLIC","TITLE":"ERPNext - Stored XSS in My Profile"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"frappe","version":{"version_data":[{"version_affected":">=","version_value":"v12.0.9"},{"version_affected":"<=","version_value":"v13.0.3"}]}}]},"vendor_name":"frappe"}]}},"credit":[{"lang":"eng","value":"Mend Vulnerability Research Team (MVR)"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"In ERPNext, versions v12.0.9--v13.0.3 are vulnerable to Stored Cross-Site-Scripting (XSS), due to user input not being validated properly. A low privileged attacker could inject arbitrary code into input fields when editing his profile."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":3.1}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}]},"references":{"reference_data":[{"name":"https://www.mend.io/vulnerability-database/CVE-2022-23057","refsource":"MISC","url":"https://www.mend.io/vulnerability-database/CVE-2022-23057"},{"name":"https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7","refsource":"MISC","url":"https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7"}]},"solution":[{"lang":"en","value":"Update version to v13.1.0 or later"}],"source":{"advisory":"https://www.mend.io/vulnerability-database/","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.mend.io/vulnerability-database/CVE-2022-23057","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/frappe/frappe/commit/497ea861f481c6a3c52fe2aed9d0df1b6c99e9d7","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T03:28:43.256Z"}}]}}}