{"id":"CVE-2022-2305","state":"PUBLISHED","title":"WordPress Popup <= 1.9.3.8 - Admin+ Stored Cross-Site Scripting","description":"The WordPress Popup WordPress plugin through 1.9.3.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)","publishedAt":"2022-08-01T12:51:48.000Z","updatedAt":"2024-08-03T00:32:09.697Z","severity":null,"assigner":"WPScan","products":["Unknown Popups – WordPress Popup"],"affected":[{"vendor":"Unknown","product":"Popups – WordPress Popup","versions":[{"version":"1.9.3.8","status":"affected","lessThanOrEqual":"1.9.3.8","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/ea0180cd-e018-43ea-88b9-fa8e71bf34bf"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:50:01.354Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/2xxx/CVE-2022-2305.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-2305","state":"PUBLISHED","datePublished":"2022-08-01T12:51:48.000Z","dateUpdated":"2024-08-03T00:32:09.697Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-07-04T00:00:00.000Z"},"containers":{"cna":{"title":"WordPress Popup <= 1.9.3.8 - Admin+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WordPress Popup WordPress plugin through 1.9.3.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)"}],"affected":[{"vendor":"Unknown","product":"Popups – WordPress Popup","versions":[{"version":"1.9.3.8","status":"affected","lessThanOrEqual":"1.9.3.8","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/ea0180cd-e018-43ea-88b9-fa8e71bf34bf","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-08-01T12:51:48.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Raad Haddad"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-2305","STATE":"PUBLIC","TITLE":"WordPress Popup <= 1.9.3.8 - Admin+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Popups – WordPress Popup","version":{"version_data":[{"version_affected":"<=","version_name":"1.9.3.8","version_value":"1.9.3.8"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Raad Haddad"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WordPress Popup WordPress plugin through 1.9.3.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/ea0180cd-e018-43ea-88b9-fa8e71bf34bf","refsource":"MISC","url":"https://wpscan.com/vulnerability/ea0180cd-e018-43ea-88b9-fa8e71bf34bf"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/ea0180cd-e018-43ea-88b9-fa8e71bf34bf","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:32:09.697Z"}}]}}}