{"id":"CVE-2022-22978","state":"PUBLISHED","title":"In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet contain","description":"In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass.","publishedAt":"2022-05-19T00:00:00.000Z","updatedAt":"2024-08-03T03:28:42.507Z","severity":null,"assigner":"vmware","products":["n/a Spring Security"],"affected":[{"vendor":"n/a","product":"Spring Security","versions":[{"version":"Spring security versions 5.4.x prior to 5.4.11+,5.5.x prior to 5.5.7+,5.6.x prior to 5.6.4+ and all earlier unsupported versions","status":"affected"}]}],"references":["https://spring.io/security/cve-2022-22978"],"weaknesses":["CWE-863"],"ingestedAt":"2026-10-29T19:49:38.433Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/22xxx/CVE-2022-22978.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-22978","state":"PUBLISHED","datePublished":"2022-05-19T00:00:00.000Z","dateUpdated":"2024-08-03T03:28:42.507Z","assignerShortName":"vmware","assignerOrgId":"dcf2e128-44bd-42ed-91e8-88f912c1401d","dateReserved":"2022-01-10T00:00:00.000Z"},"containers":{"cna":{"descriptions":[{"lang":"en","value":"In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass."}],"affected":[{"vendor":"n/a","product":"Spring Security","versions":[{"version":"Spring security versions 5.4.x prior to 5.4.11+,5.5.x prior to 5.5.7+,5.6.x prior to 5.6.4+ and all earlier unsupported versions","status":"affected"}]}],"references":[{"url":"https://spring.io/security/cve-2022-22978"}],"problemTypes":[{"descriptions":[{"cweId":"CWE-863","type":"CWE","lang":"en","description":"CWE-863- improper authorization"}]}],"providerMetadata":{"shortName":"vmware","orgId":"dcf2e128-44bd-42ed-91e8-88f912c1401d","dateUpdated":"2023-04-11T00:00:00.000Z"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://spring.io/security/cve-2022-22978","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T03:28:42.507Z"}}]}}}