{"id":"CVE-2022-21721","state":"PUBLISHED","title":"DOS Vulnerability in next.js","description":"Next.js is a React framework. Starting with version 12.0.0 and prior to version 12.0.9, vulnerable code could allow a bad actor to trigger a denial of service attack for anyone using i18n functionality. In order to be affected by this CVE, one must use next start or a custom server and the built-in i18n support. Deployments on Vercel, along with similar environments where invalid requests are filtered before reaching Next.js, are not affected. A patch has been released, `next@12.0.9`, that mitigates this issue. As a workaround, one may ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until it becomes feasible to upgrade.","publishedAt":"2022-01-28T22:00:17.000Z","updatedAt":"2025-05-05T16:33:30.538Z","severity":{"score":5.9,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["n/a n/a"],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":["https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x","https://github.com/vercel/next.js/pull/33503","https://github.com/vercel/next.js/releases/tag/v12.0.9"],"weaknesses":[],"ingestedAt":"2026-10-29T19:49:35.025Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/21xxx/CVE-2022-21721.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-21721","state":"PUBLISHED","datePublished":"2022-01-28T22:00:17.000Z","dateUpdated":"2025-05-05T16:33:30.538Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2021-11-16T00:00:00.000Z"},"containers":{"cna":{"title":"DOS Vulnerability in next.js","descriptions":[{"lang":"en","value":"Next.js is a React framework. Starting with version 12.0.0 and prior to version 12.0.9, vulnerable code could allow a bad actor to trigger a denial of service attack for anyone using i18n functionality. In order to be affected by this CVE, one must use next start or a custom server and the built-in i18n support. Deployments on Vercel, along with similar environments where invalid requests are filtered before reaching Next.js, are not affected. A patch has been released, `next@12.0.9`, that mitigates this issue. As a workaround, one may ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until it becomes feasible to upgrade."}],"affected":[{"vendor":"n/a","product":"n/a","versions":[{"version":"n/a","status":"affected"}]}],"references":[{"url":"https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/vercel/next.js/pull/33503","tags":["x_refsource_MISC"]},{"url":"https://github.com/vercel/next.js/releases/tag/v12.0.9","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":5.9,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"description":"n/a","lang":"en","type":"text"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-01-28T22:00:17.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-wr66-vrwm-5g5x","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-21721","STATE":"PUBLIC","TITLE":"DOS Vulnerability in next.js"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"n/a","version":{"version_data":[{"version_value":"n/a"}]}}]},"vendor_name":"n/a"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Next.js is a React framework. Starting with version 12.0.0 and prior to version 12.0.9, vulnerable code could allow a bad actor to trigger a denial of service attack for anyone using i18n functionality. In order to be affected by this CVE, one must use next start or a custom server and the built-in i18n support. Deployments on Vercel, along with similar environments where invalid requests are filtered before reaching Next.js, are not affected. A patch has been released, `next@12.0.9`, that mitigates this issue. As a workaround, one may ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until it becomes feasible to upgrade."}]},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":5.9,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"n/a"}]}]},"references":{"reference_data":[{"name":"https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x","refsource":"CONFIRM","url":"https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x"},{"name":"https://github.com/vercel/next.js/pull/33503","refsource":"MISC","url":"https://github.com/vercel/next.js/pull/33503"},{"name":"https://github.com/vercel/next.js/releases/tag/v12.0.9","refsource":"MISC","url":"https://github.com/vercel/next.js/releases/tag/v12.0.9"}]},"source":{"advisory":"GHSA-wr66-vrwm-5g5x","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/vercel/next.js/pull/33503","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/vercel/next.js/releases/tag/v12.0.9","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T02:53:35.543Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-25T15:46:29.621509Z","id":"CVE-2022-21721","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"type":"CWE","lang":"en","description":"CWE-noinfo Not enough information"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-05T16:33:30.538Z"}}]}}}