{"id":"CVE-2022-21652","state":"PUBLISHED","title":"Insufficient Session Expiration in shopware","description":"Shopware is an open source e-commerce software platform. In affected versions shopware would not invalidate a user session in the event of a password change. With version 5.7.7 the session validation was adjusted, so that sessions created prior to the latest password change of a customer account can't be used to login with said account. This also means, that upon a password change, all existing sessions for a given customer account are automatically considered invalid. There is no workaround for this issue.","publishedAt":"2022-01-05T19:20:18.000Z","updatedAt":"2025-04-23T19:14:34.905Z","severity":{"score":3.5,"label":"Low","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["shopware shopware"],"affected":[{"vendor":"shopware","product":"shopware","versions":[{"version":">=5.7.3, < 5.7.7","status":"affected"}]}],"references":["https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022","https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6","https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0"],"weaknesses":["CWE-613"],"ingestedAt":"2026-10-29T19:49:35.025Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/21xxx/CVE-2022-21652.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-21652","state":"PUBLISHED","datePublished":"2022-01-05T19:20:18.000Z","dateUpdated":"2025-04-23T19:14:34.905Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2021-11-16T00:00:00.000Z"},"containers":{"cna":{"title":"Insufficient Session Expiration in shopware","descriptions":[{"lang":"en","value":"Shopware is an open source e-commerce software platform. In affected versions shopware would not invalidate a user session in the event of a password change. With version 5.7.7 the session validation was adjusted, so that sessions created prior to the latest password change of a customer account can't be used to login with said account. This also means, that upon a password change, all existing sessions for a given customer account are automatically considered invalid. There is no workaround for this issue."}],"affected":[{"vendor":"shopware","product":"shopware","versions":[{"version":">=5.7.3, < 5.7.7","status":"affected"}]}],"references":[{"url":"https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022","tags":["x_refsource_MISC"]},{"url":"https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":3.5,"baseSeverity":"LOW","confidentialityImpact":"LOW","integrityImpact":"NONE","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-613","description":"CWE-613: Insufficient Session Expiration","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2022-01-05T19:20:18.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-p523-jrph-qjc6","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2022-21652","STATE":"PUBLIC","TITLE":"Insufficient Session Expiration in shopware"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"shopware","version":{"version_data":[{"version_value":">=5.7.3, < 5.7.7"}]}}]},"vendor_name":"shopware"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Shopware is an open source e-commerce software platform. In affected versions shopware would not invalidate a user session in the event of a password change. With version 5.7.7 the session validation was adjusted, so that sessions created prior to the latest password change of a customer account can't be used to login with said account. This also means, that upon a password change, all existing sessions for a given customer account are automatically considered invalid. There is no workaround for this issue."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":3.5,"baseSeverity":"LOW","confidentialityImpact":"LOW","integrityImpact":"NONE","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-613: Insufficient Session Expiration"}]}]},"references":{"reference_data":[{"name":"https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022","refsource":"MISC","url":"https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022"},{"name":"https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6","refsource":"CONFIRM","url":"https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6"},{"name":"https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0","refsource":"MISC","url":"https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0"}]},"source":{"advisory":"GHSA-p523-jrph-qjc6","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T02:46:39.393Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T14:12:32.187335Z","id":"CVE-2022-21652","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-23T19:14:34.905Z"}}]}}}