{"id":"CVE-2022-2123","state":"PUBLISHED","title":"WP Opt-in <= 1.4.1 - Arbitrary Settings Update via CSRF","description":"The WP Opt-in WordPress plugin through 1.4.1 is vulnerable to CSRF which allows changed plugin settings and can be used for sending spam emails.","publishedAt":"2022-07-11T12:57:36.000Z","updatedAt":"2024-08-03T00:24:44.249Z","severity":null,"assigner":"WPScan","products":["Unknown WP Opt-in"],"affected":[{"vendor":"Unknown","product":"WP Opt-in","versions":[{"version":"1.4.1","status":"affected","lessThanOrEqual":"1.4.1","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/46b634f6-92bc-4e00-a4c0-c25135c61922"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T19:50:01.354Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/2xxx/CVE-2022-2123.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-2123","state":"PUBLISHED","datePublished":"2022-07-11T12:57:36.000Z","dateUpdated":"2024-08-03T00:24:44.249Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-06-18T00:00:00.000Z"},"containers":{"cna":{"title":"WP Opt-in <= 1.4.1 - Arbitrary Settings Update via CSRF","descriptions":[{"lang":"en","value":"The WP Opt-in WordPress plugin through 1.4.1 is vulnerable to CSRF which allows changed plugin settings and can be used for sending spam emails."}],"affected":[{"vendor":"Unknown","product":"WP Opt-in","versions":[{"version":"1.4.1","status":"affected","lessThanOrEqual":"1.4.1","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/46b634f6-92bc-4e00-a4c0-c25135c61922","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","description":"CWE-352 Cross-Site Request Forgery (CSRF)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-07-11T12:57:36.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Daniel Ruf"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-2123","STATE":"PUBLIC","TITLE":"WP Opt-in <= 1.4.1 - Arbitrary Settings Update via CSRF"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP Opt-in","version":{"version_data":[{"version_affected":"<=","version_name":"1.4.1","version_value":"1.4.1"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Daniel Ruf"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WP Opt-in WordPress plugin through 1.4.1 is vulnerable to CSRF which allows changed plugin settings and can be used for sending spam emails."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-352 Cross-Site Request Forgery (CSRF)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/46b634f6-92bc-4e00-a4c0-c25135c61922","refsource":"MISC","url":"https://wpscan.com/vulnerability/46b634f6-92bc-4e00-a4c0-c25135c61922"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/46b634f6-92bc-4e00-a4c0-c25135c61922","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:24:44.249Z"}}]}}}