{"id":"CVE-2022-2118","state":"PUBLISHED","title":"404s < 3.5.1 - Admin+ Stored Cross-Site Scripting","description":"The 404s WordPress plugin before 3.5.1 does not sanitise and escape its fields, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.","publishedAt":"2022-07-17T10:36:11.000Z","updatedAt":"2024-08-03T00:24:44.265Z","severity":null,"assigner":"WPScan","products":["Unknown 404s"],"affected":[{"vendor":"Unknown","product":"404s","versions":[{"version":"3.5.1","status":"affected","lessThan":"3.5.1","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/9a19af60-d6e6-4fa3-82eb-3636599b814c"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:50:01.354Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/2xxx/CVE-2022-2118.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-2118","state":"PUBLISHED","datePublished":"2022-07-17T10:36:11.000Z","dateUpdated":"2024-08-03T00:24:44.265Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-06-17T00:00:00.000Z"},"containers":{"cna":{"title":"404s < 3.5.1 - Admin+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The 404s WordPress plugin before 3.5.1 does not sanitise and escape its fields, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed."}],"affected":[{"vendor":"Unknown","product":"404s","versions":[{"version":"3.5.1","status":"affected","lessThan":"3.5.1","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/9a19af60-d6e6-4fa3-82eb-3636599b814c","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-07-17T10:36:11.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Vivek Kumar Jaiswal"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-2118","STATE":"PUBLIC","TITLE":"404s < 3.5.1 - Admin+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"404s","version":{"version_data":[{"version_affected":"<","version_name":"3.5.1","version_value":"3.5.1"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Vivek Kumar Jaiswal"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The 404s WordPress plugin before 3.5.1 does not sanitise and escape its fields, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/9a19af60-d6e6-4fa3-82eb-3636599b814c","refsource":"MISC","url":"https://wpscan.com/vulnerability/9a19af60-d6e6-4fa3-82eb-3636599b814c"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/9a19af60-d6e6-4fa3-82eb-3636599b814c","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:24:44.265Z"}}]}}}