{"id":"CVE-2022-2050","state":"PUBLISHED","title":"WP Paginate < 2.1.9 - Admin+ Stored Cross-Site Scripting","description":"The WP-Paginate WordPress plugin before 2.1.9 does not escape one of its settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when unfiltered_html is disallowed","publishedAt":"2022-07-11T12:57:09.000Z","updatedAt":"2024-08-03T00:24:44.187Z","severity":null,"assigner":"WPScan","products":["Unknown WP-Paginate"],"affected":[{"vendor":"Unknown","product":"WP-Paginate","versions":[{"version":"2.1.9","status":"affected","lessThan":"2.1.9","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/016453e3-803b-4a67-8ea7-2d228c2998d4"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:50:01.354Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/2xxx/CVE-2022-2050.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-2050","state":"PUBLISHED","datePublished":"2022-07-11T12:57:09.000Z","dateUpdated":"2024-08-03T00:24:44.187Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-06-10T00:00:00.000Z"},"containers":{"cna":{"title":"WP Paginate < 2.1.9 - Admin+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WP-Paginate WordPress plugin before 2.1.9 does not escape one of its settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when unfiltered_html is disallowed"}],"affected":[{"vendor":"Unknown","product":"WP-Paginate","versions":[{"version":"2.1.9","status":"affected","lessThan":"2.1.9","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/016453e3-803b-4a67-8ea7-2d228c2998d4","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-07-11T12:57:09.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"iohex"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-2050","STATE":"PUBLIC","TITLE":"WP Paginate < 2.1.9 - Admin+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP-Paginate","version":{"version_data":[{"version_affected":"<","version_name":"2.1.9","version_value":"2.1.9"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"iohex"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WP-Paginate WordPress plugin before 2.1.9 does not escape one of its settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when unfiltered_html is disallowed"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/016453e3-803b-4a67-8ea7-2d228c2998d4","refsource":"MISC","url":"https://wpscan.com/vulnerability/016453e3-803b-4a67-8ea7-2d228c2998d4"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/016453e3-803b-4a67-8ea7-2d228c2998d4","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:24:44.187Z"}}]}}}