{"id":"CVE-2022-1971","state":"PUBLISHED","title":"NextCellent Gallery <= 1.9.35 - Admin+ Stored XSS","description":"The NextCellent Gallery WordPress plugin through 1.9.35 does not sanitise and escape some of its image settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)","publishedAt":"2022-06-27T08:59:02.000Z","updatedAt":"2024-08-03T00:24:44.067Z","severity":null,"assigner":"WPScan","products":["Unknown NextCellent Gallery – NextGEN Legacy"],"affected":[{"vendor":"Unknown","product":"NextCellent Gallery – NextGEN Legacy","versions":[{"version":"1.9.35","status":"affected","lessThanOrEqual":"1.9.35","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/1bffbbef-7876-43a6-9cb0-6e09bb4ff2b0"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:49:29.138Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/1xxx/CVE-2022-1971.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-1971","state":"PUBLISHED","datePublished":"2022-06-27T08:59:02.000Z","dateUpdated":"2024-08-03T00:24:44.067Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-06-01T00:00:00.000Z"},"containers":{"cna":{"title":"NextCellent Gallery <= 1.9.35 - Admin+ Stored XSS","descriptions":[{"lang":"en","value":"The NextCellent Gallery WordPress plugin through 1.9.35 does not sanitise and escape some of its image settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)"}],"affected":[{"vendor":"Unknown","product":"NextCellent Gallery – NextGEN Legacy","versions":[{"version":"1.9.35","status":"affected","lessThanOrEqual":"1.9.35","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/1bffbbef-7876-43a6-9cb0-6e09bb4ff2b0","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-06-27T08:59:02.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"lucy"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-1971","STATE":"PUBLIC","TITLE":"NextCellent Gallery <= 1.9.35 - Admin+ Stored XSS"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"NextCellent Gallery – NextGEN Legacy","version":{"version_data":[{"version_affected":"<=","version_name":"1.9.35","version_value":"1.9.35"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"lucy"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The NextCellent Gallery WordPress plugin through 1.9.35 does not sanitise and escape some of its image settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/1bffbbef-7876-43a6-9cb0-6e09bb4ff2b0","refsource":"MISC","url":"https://wpscan.com/vulnerability/1bffbbef-7876-43a6-9cb0-6e09bb4ff2b0"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/1bffbbef-7876-43a6-9cb0-6e09bb4ff2b0","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:24:44.067Z"}}]}}}