{"id":"CVE-2022-1912","state":"PUBLISHED","title":"Button Widget Smartsoft <= 1.0.1 - Cross-Site Request Forgery to Cross-Site Scripting","description":"The Button Widget Smartsoft plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.1. This is due to missing nonce validation on the smartsoftbutton_settings page. This makes it possible for unauthenticated attackers to update the plugins settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.","publishedAt":"2022-07-18T16:16:27.000Z","updatedAt":"2026-04-08T16:53:04.877Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["smartsoftbuttonwidget Button Widget Smartsoft"],"affected":[{"vendor":"smartsoftbuttonwidget","product":"Button Widget Smartsoft","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.1","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/53757567-5024-46cc-b2ae-04b5fc55a35c?source=cve","https://plugins.trac.wordpress.org/browser/smartsoftbutton-widget-de-botones-de-chat/trunk/admin/pages/settings.php#L60","https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1912"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T19:49:29.138Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/1xxx/CVE-2022-1912.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2022-1912","state":"PUBLISHED","datePublished":"2022-07-18T16:16:27.000Z","dateUpdated":"2026-04-08T16:53:04.877Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2022-05-27T00:00:00.000Z"},"containers":{"cna":{"title":"Button Widget Smartsoft <= 1.0.1 - Cross-Site Request Forgery to Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Button Widget Smartsoft plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.1. This is due to missing nonce validation on the smartsoftbutton_settings page. This makes it possible for unauthenticated attackers to update the plugins settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link."}],"affected":[{"vendor":"smartsoftbuttonwidget","product":"Button Widget Smartsoft","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThanOrEqual":"1.0.1","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/53757567-5024-46cc-b2ae-04b5fc55a35c?source=cve"},{"url":"https://plugins.trac.wordpress.org/browser/smartsoftbutton-widget-de-botones-de-chat/trunk/admin/pages/settings.php#L60"},{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1912"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","baseScore":8.8,"baseSeverity":"HIGH"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T16:53:04.877Z"},"credits":[{"lang":"en","type":"finder","value":"Ryo Onodera , a member of Cryptography Laboratory in Tokyo Denki University."}],"timeline":[{"time":"2022-06-16T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/53757567-5024-46cc-b2ae-04b5fc55a35c?source=cve","tags":["x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/smartsoftbutton-widget-de-botones-de-chat/trunk/admin/pages/settings.php#L60","tags":["x_transferred"]},{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-1912","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:17:00.963Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-04-23T13:14:21.872360Z","id":"CVE-2022-1912","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"total"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","type":"CWE","lang":"en","description":"CWE-352 Cross-Site Request Forgery (CSRF)"}]}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-05T16:40:39.499Z"}}]}}}