{"id":"CVE-2022-1761","state":"PUBLISHED","title":"Peter’s Collaboration E-mails <= 2.2.0 - Arbitrary Settings Update via CSRF","description":"The Peter’s Collaboration E-mails WordPress plugin through 2.2.0 is vulnerable to CSRF due to missing nonce checks. This allows the change of its settings, which can be used to lower the required user level, change texts, the used email address and more.","publishedAt":"2022-06-13T12:42:37.000Z","updatedAt":"2024-08-03T00:16:59.654Z","severity":null,"assigner":"WPScan","products":["Unknown Peter’s Collaboration E-mails"],"affected":[{"vendor":"Unknown","product":"Peter’s Collaboration E-mails","versions":[{"version":"2.2.0","status":"affected","lessThanOrEqual":"2.2.0","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/31b413e1-d4b5-463e-9910-37876881c062"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T19:49:29.138Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/1xxx/CVE-2022-1761.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-1761","state":"PUBLISHED","datePublished":"2022-06-13T12:42:37.000Z","dateUpdated":"2024-08-03T00:16:59.654Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-05-17T00:00:00.000Z"},"containers":{"cna":{"title":"Peter’s Collaboration E-mails <= 2.2.0 - Arbitrary Settings Update via CSRF","descriptions":[{"lang":"en","value":"The Peter’s Collaboration E-mails WordPress plugin through 2.2.0 is vulnerable to CSRF due to missing nonce checks. This allows the change of its settings, which can be used to lower the required user level, change texts, the used email address and more."}],"affected":[{"vendor":"Unknown","product":"Peter’s Collaboration E-mails","versions":[{"version":"2.2.0","status":"affected","lessThanOrEqual":"2.2.0","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/31b413e1-d4b5-463e-9910-37876881c062","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","description":"CWE-352 Cross-Site Request Forgery (CSRF)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-06-13T12:42:37.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Daniel Ruf"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-1761","STATE":"PUBLIC","TITLE":"Peter’s Collaboration E-mails <= 2.2.0 - Arbitrary Settings Update via CSRF"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Peter’s Collaboration E-mails","version":{"version_data":[{"version_affected":"<=","version_name":"2.2.0","version_value":"2.2.0"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Daniel Ruf"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Peter’s Collaboration E-mails WordPress plugin through 2.2.0 is vulnerable to CSRF due to missing nonce checks. This allows the change of its settings, which can be used to lower the required user level, change texts, the used email address and more."}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-352 Cross-Site Request Forgery (CSRF)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/31b413e1-d4b5-463e-9910-37876881c062","refsource":"MISC","url":"https://wpscan.com/vulnerability/31b413e1-d4b5-463e-9910-37876881c062"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/31b413e1-d4b5-463e-9910-37876881c062","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:16:59.654Z"}}]}}}