{"id":"CVE-2022-1581","state":"PUBLISHED","title":"WP-Polls < 2.76.0 - IP Validation Bypass","description":"The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations.","publishedAt":"2022-11-21T00:00:00.000Z","updatedAt":"2025-04-30T15:00:03.896Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","source":"CISA-ADP"},"assigner":"WPScan","products":["Unknown WP-Polls"],"affected":[{"vendor":"Unknown","product":"WP-Polls","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2.76.0","versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":["https://wpscan.com/vulnerability/c1896ab9-9585-40e2-abbf-ef5153b3c6b2","https://www.hightechdad.com/2009/12/21/warning-wp-polls-wordpress-poll-plugin-can-be-exploited/"],"weaknesses":[],"ingestedAt":"2026-10-29T19:49:29.138Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/1xxx/CVE-2022-1581.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-1581","state":"PUBLISHED","datePublished":"2022-11-21T00:00:00.000Z","dateUpdated":"2025-04-30T15:00:03.896Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-05-04T00:00:00.000Z"},"containers":{"cna":{"title":"WP-Polls < 2.76.0 - IP Validation Bypass","descriptions":[{"lang":"en","value":"The WP-Polls WordPress plugin before 2.76.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations to vote in certain situations."}],"affected":[{"vendor":"Unknown","product":"WP-Polls","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2.76.0","versionType":"custom"}],"collectionURL":"https://wordpress.org/plugins"}],"references":[{"url":"https://wpscan.com/vulnerability/c1896ab9-9585-40e2-abbf-ef5153b3c6b2","tags":["exploit","vdb-entry","technical-description"]},{"url":"https://www.hightechdad.com/2009/12/21/warning-wp-polls-wordpress-poll-plugin-can-be-exploited/"}],"problemTypes":[{"descriptions":[{"description":"CWE-639 Authorization Bypass Through User-Controlled Key","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateUpdated":"2022-11-29T13:34:54.044Z"},"credits":[{"lang":"en","value":"Daniel Ruf","type":"finder"}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"WPScan CVE Generator"}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/c1896ab9-9585-40e2-abbf-ef5153b3c6b2","tags":["exploit","vdb-entry","technical-description","x_transferred"]},{"url":"https://www.hightechdad.com/2009/12/21/warning-wp-polls-wordpress-poll-plugin-can-be-exploited/","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:10:03.682Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"cvssV3_1":{"scope":"UNCHANGED","version":"3.1","baseScore":5.3,"attackVector":"NETWORK","baseSeverity":"MEDIUM","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","integrityImpact":"LOW","userInteraction":"NONE","attackComplexity":"LOW","availabilityImpact":"NONE","privilegesRequired":"NONE","confidentialityImpact":"NONE"}},{"other":{"type":"ssvc","content":{"timestamp":"2025-04-30T14:59:29.008321Z","id":"CVE-2022-1581","options":[{"Exploitation":"poc"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-04-30T15:00:03.896Z"}}]}}}