{"id":"CVE-2022-1384","state":"PUBLISHED","title":"Authorized users are allowed to install old plugin versions from the Marketplace","description":"Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which allows an authenticated and an authorized user to install and exploit an old plugin version from the Marketplace which might have known vulnerabilities.","publishedAt":"2022-04-19T20:26:28.000Z","updatedAt":"2024-12-06T23:09:22.478Z","severity":{"score":4.7,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L","source":"Mattermost"},"assigner":"Mattermost","products":["Mattermost Mattermost"],"affected":[{"vendor":"Mattermost","product":"Mattermost","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"6.4","versionType":"custom"}]}],"references":["https://mattermost.com/security-updates/"],"weaknesses":["CWE-477"],"ingestedAt":"2026-10-29T19:49:29.138Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/1xxx/CVE-2022-1384.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-1384","state":"PUBLISHED","datePublished":"2022-04-19T20:26:28.000Z","dateUpdated":"2024-12-06T23:09:22.478Z","assignerShortName":"Mattermost","assignerOrgId":"9302f53e-dde5-4bf3-b2f2-a83f91ac0eee","dateReserved":"2022-04-18T00:00:00.000Z"},"containers":{"cna":{"title":"Authorized users are allowed to install old plugin versions from the Marketplace","descriptions":[{"lang":"en","value":"Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which allows an authenticated and an authorized user to install and exploit an old plugin version from the Marketplace which might have known vulnerabilities."}],"affected":[{"vendor":"Mattermost","product":"Mattermost","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"6.4","versionType":"custom"}]}],"references":[{"url":"https://mattermost.com/security-updates/","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":4.7,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-477","description":"CWE-477 Use of Obsolete Function","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Mattermost","dateUpdated":"2022-04-19T20:26:28.000Z","orgId":"9302f53e-dde5-4bf3-b2f2-a83f91ac0eee"},"credits":[{"lang":"en","value":"Thanks to Rohitesh Gupta for contributing to this improvement under the Mattermost responsible disclosure policy."}],"solutions":[{"lang":"en","value":"Update Mattermost to version v6.5 or higher"}],"source":{"advisory":"MMSA-2022-0095","defect":["https://mattermost.atlassian.net/browse/MM-41885"],"discovery":"INTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"responsibledisclosure@mattermost.com","ID":"CVE-2022-1384","STATE":"PUBLIC","TITLE":"Authorized users are allowed to install old plugin versions from the Marketplace"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Mattermost","version":{"version_data":[{"version_affected":"<=","version_value":"6.4"}]}}]},"vendor_name":"Mattermost"}]}},"credit":[{"lang":"eng","value":"Thanks to Rohitesh Gupta for contributing to this improvement under the Mattermost responsible disclosure policy."}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which allows an authenticated and an authorized user to install and exploit an old plugin version from the Marketplace which might have known vulnerabilities."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":4.7,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-477 Use of Obsolete Function"}]}]},"references":{"reference_data":[{"name":"https://mattermost.com/security-updates/","refsource":"MISC","url":"https://mattermost.com/security-updates/"}]},"solution":[{"lang":"en","value":"Update Mattermost to version v6.5 or higher"}],"source":{"advisory":"MMSA-2022-0095","defect":["https://mattermost.atlassian.net/browse/MM-41885"],"discovery":"INTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://mattermost.com/security-updates/","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T00:03:06.265Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-06T22:52:58.546800Z","id":"CVE-2022-1384","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-06T23:09:22.478Z"}}]}}}