{"id":"CVE-2022-1255","state":"PUBLISHED","title":"Import and export users and customers < 1.19.2.1 - Admin+ Stored Cross-Site Scripting","description":"The Import and export users and customers WordPress plugin before 1.19.2.1 does not sanitise and escaped imported CSV data, which could allow high privilege users to import malicious javascript code and lead to Stored Cross-Site Scripting issues","publishedAt":"2022-05-02T16:05:52.000Z","updatedAt":"2024-08-02T23:55:24.548Z","severity":null,"assigner":"WPScan","products":["Unknown Import and export users and customers"],"affected":[{"vendor":"Unknown","product":"Import and export users and customers","versions":[{"version":"1.19.2.1","status":"affected","lessThan":"1.19.2.1","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/22fe68c4-8f47-491e-be87-5e8e40535a82"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:49:29.138Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/1xxx/CVE-2022-1255.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-1255","state":"PUBLISHED","datePublished":"2022-05-02T16:05:52.000Z","dateUpdated":"2024-08-02T23:55:24.548Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-04-06T00:00:00.000Z"},"containers":{"cna":{"title":"Import and export users and customers < 1.19.2.1 - Admin+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Import and export users and customers WordPress plugin before 1.19.2.1 does not sanitise and escaped imported CSV data, which could allow high privilege users to import malicious javascript code and lead to Stored Cross-Site Scripting issues"}],"affected":[{"vendor":"Unknown","product":"Import and export users and customers","versions":[{"version":"1.19.2.1","status":"affected","lessThan":"1.19.2.1","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/22fe68c4-8f47-491e-be87-5e8e40535a82","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-05-02T16:05:52.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"0x23.so"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-1255","STATE":"PUBLIC","TITLE":"Import and export users and customers < 1.19.2.1 - Admin+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Import and export users and customers","version":{"version_data":[{"version_affected":"<","version_name":"1.19.2.1","version_value":"1.19.2.1"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"0x23.so"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Import and export users and customers WordPress plugin before 1.19.2.1 does not sanitise and escaped imported CSV data, which could allow high privilege users to import malicious javascript code and lead to Stored Cross-Site Scripting issues"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/22fe68c4-8f47-491e-be87-5e8e40535a82","refsource":"MISC","url":"https://wpscan.com/vulnerability/22fe68c4-8f47-491e-be87-5e8e40535a82"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/22fe68c4-8f47-491e-be87-5e8e40535a82","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T23:55:24.548Z"}}]}}}