{"id":"CVE-2022-1001","state":"PUBLISHED","title":"WP Downgrade < 1.2.3 - Admin+ Stored Cross-Site Scripting","description":"The WP Downgrade WordPress plugin before 1.2.3 only perform client side validation of its \"WordPress Target Version\" settings, but does not sanitise and escape it server side, allowing high privilege users such as admin to perform Cross-Site attacks even when the unfiltered_html capability is disallowed","publishedAt":"2022-04-18T17:10:42.000Z","updatedAt":"2024-08-02T23:47:43.232Z","severity":null,"assigner":"WPScan","products":["Unknown WP Downgrade | Specific Core Version"],"affected":[{"vendor":"Unknown","product":"WP Downgrade | Specific Core Version","versions":[{"version":"1.2.3","status":"affected","lessThan":"1.2.3","versionType":"custom"}]}],"references":["https://wpscan.com/vulnerability/34a7b3cd-e2b5-4891-ab33-af6a2a0eeceb","https://plugins.trac.wordpress.org/changeset/2696091"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:49:29.138Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/1xxx/CVE-2022-1001.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-1001","state":"PUBLISHED","datePublished":"2022-04-18T17:10:42.000Z","dateUpdated":"2024-08-02T23:47:43.232Z","assignerShortName":"WPScan","assignerOrgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81","dateReserved":"2022-03-17T00:00:00.000Z"},"containers":{"cna":{"title":"WP Downgrade < 1.2.3 - Admin+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WP Downgrade WordPress plugin before 1.2.3 only perform client side validation of its \"WordPress Target Version\" settings, but does not sanitise and escape it server side, allowing high privilege users such as admin to perform Cross-Site attacks even when the unfiltered_html capability is disallowed"}],"affected":[{"vendor":"Unknown","product":"WP Downgrade | Specific Core Version","versions":[{"version":"1.2.3","status":"affected","lessThan":"1.2.3","versionType":"custom"}]}],"references":[{"url":"https://wpscan.com/vulnerability/34a7b3cd-e2b5-4891-ab33-af6a2a0eeceb","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/changeset/2696091","tags":["x_refsource_CONFIRM"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"WPScan","dateUpdated":"2022-04-18T17:10:42.000Z","orgId":"1bfdd5d7-9bf6-4a53-96ea-42e2716d7a81"},"credits":[{"lang":"en","value":"Taurus Omar"}],"source":{"discovery":"EXTERNAL"},"x_generator":"WPScan CVE Generator","x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"contact@wpscan.com","ID":"CVE-2022-1001","STATE":"PUBLIC","TITLE":"WP Downgrade < 1.2.3 - Admin+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP Downgrade | Specific Core Version","version":{"version_data":[{"version_affected":"<","version_name":"1.2.3","version_value":"1.2.3"}]}}]},"vendor_name":"Unknown"}]}},"credit":[{"lang":"eng","value":"Taurus Omar"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WP Downgrade WordPress plugin before 1.2.3 only perform client side validation of its \"WordPress Target Version\" settings, but does not sanitise and escape it server side, allowing high privilege users such as admin to perform Cross-Site attacks even when the unfiltered_html capability is disallowed"}]},"generator":"WPScan CVE Generator","problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wpscan.com/vulnerability/34a7b3cd-e2b5-4891-ab33-af6a2a0eeceb","refsource":"MISC","url":"https://wpscan.com/vulnerability/34a7b3cd-e2b5-4891-ab33-af6a2a0eeceb"},{"name":"https://plugins.trac.wordpress.org/changeset/2696091","refsource":"CONFIRM","url":"https://plugins.trac.wordpress.org/changeset/2696091"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wpscan.com/vulnerability/34a7b3cd-e2b5-4891-ab33-af6a2a0eeceb","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/2696091","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T23:47:43.232Z"}}]}}}