{"id":"CVE-2022-0236","state":"PUBLISHED","title":"WP Import Export (Lite) <= 3.9.15 Unauthenticated Sensitive Data Disclosure","description":"The WP Import Export WordPress plugin (both free and premium versions) is vulnerable to unauthenticated sensitive data disclosure due to a missing capability check on the download function wpie_process_file_download found in the ~/includes/classes/class-wpie-general.php file. This made it possible for unauthenticated attackers to download any imported or exported information from a vulnerable site which can contain sensitive information like user data. This affects versions up to, and including, 3.9.15.","publishedAt":"2022-01-18T16:52:22.000Z","updatedAt":"2025-01-31T18:56:49.316Z","severity":{"score":7.5,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["vjinfotech WP Import Export","vjinfotech WP Import Export Lite"],"affected":[{"vendor":"vjinfotech","product":"WP Import Export","versions":[{"version":"3.9.15","status":"affected","lessThanOrEqual":"3.9.15","versionType":"custom"}]},{"vendor":"vjinfotech","product":"WP Import Export Lite","versions":[{"version":"3.9.15","status":"affected","lessThanOrEqual":"3.9.15","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2022-0236","https://plugins.trac.wordpress.org/changeset/2649762/wp-import-export-lite/trunk/includes/classes/class-wpie-general.php","https://github.com/qurbat/CVE-2022-0236"],"weaknesses":["CWE-862"],"ingestedAt":"2026-10-29T19:49:26.075Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2022/0xxx/CVE-2022-0236.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2022-0236","state":"PUBLISHED","datePublished":"2022-01-18T16:52:22.000Z","dateUpdated":"2025-01-31T18:56:49.316Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2022-01-14T00:00:00.000Z"},"containers":{"cna":{"title":"WP Import Export (Lite) <= 3.9.15 Unauthenticated Sensitive Data Disclosure","descriptions":[{"lang":"en","value":"The WP Import Export WordPress plugin (both free and premium versions) is vulnerable to unauthenticated sensitive data disclosure due to a missing capability check on the download function wpie_process_file_download found in the ~/includes/classes/class-wpie-general.php file. This made it possible for unauthenticated attackers to download any imported or exported information from a vulnerable site which can contain sensitive information like user data. This affects versions up to, and including, 3.9.15."}],"affected":[{"vendor":"vjinfotech","product":"WP Import Export","versions":[{"version":"3.9.15","status":"affected","lessThanOrEqual":"3.9.15","versionType":"custom"}]},{"vendor":"vjinfotech","product":"WP Import Export Lite","versions":[{"version":"3.9.15","status":"affected","lessThanOrEqual":"3.9.15","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-0236","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/changeset/2649762/wp-import-export-lite/trunk/includes/classes/class-wpie-general.php","tags":["x_refsource_MISC"]},{"url":"https://github.com/qurbat/CVE-2022-0236","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":7.5,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-862","description":"CWE-862 Missing Authorization","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2022-01-18T16:52:22.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Karan Saini (Kloudle Inc.)"}],"solutions":[{"lang":"en","value":"Update to version 3.9.16, or newer. "}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","ID":"CVE-2022-0236","STATE":"PUBLIC","TITLE":"WP Import Export (Lite) <= 3.9.15 Unauthenticated Sensitive Data Disclosure"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP Import Export","version":{"version_data":[{"version_affected":"<=","version_name":"3.9.15","version_value":"3.9.15"}]}},{"product_name":"WP Import Export Lite","version":{"version_data":[{"version_affected":"<=","version_name":"3.9.15","version_value":"3.9.15"}]}}]},"vendor_name":"vjinfotech"}]}},"credit":[{"lang":"eng","value":"Karan Saini (Kloudle Inc.)"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WP Import Export WordPress plugin (both free and premium versions) is vulnerable to unauthenticated sensitive data disclosure due to a missing capability check on the download function wpie_process_file_download found in the ~/includes/classes/class-wpie-general.php file. This made it possible for unauthenticated attackers to download any imported or exported information from a vulnerable site which can contain sensitive information like user data. This affects versions up to, and including, 3.9.15."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":7.5,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-862 Missing Authorization"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-0236","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-0236"},{"name":"https://plugins.trac.wordpress.org/changeset/2649762/wp-import-export-lite/trunk/includes/classes/class-wpie-general.php","refsource":"MISC","url":"https://plugins.trac.wordpress.org/changeset/2649762/wp-import-export-lite/trunk/includes/classes/class-wpie-general.php"},{"name":"https://github.com/qurbat/CVE-2022-0236","refsource":"MISC","url":"https://github.com/qurbat/CVE-2022-0236"}]},"solution":[{"lang":"en","value":"Update to version 3.9.16, or newer. "}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2022-0236","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/2649762/wp-import-export-lite/trunk/includes/classes/class-wpie-general.php","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/qurbat/CVE-2022-0236","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-02T23:18:42.926Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-01-31T18:56:42.634025Z","id":"CVE-2022-0236","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-01-31T18:56:49.316Z"}}]}}}