{"id":"CVE-2021-45068","state":"PUBLISHED","title":"Adobe Acrobat Reader DC Font Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability","description":"Acrobat Reader DC version 21.007.20099 (and earlier), 20.004.30017 (and earlier) and 17.011.30204 (and earlier) are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.","publishedAt":"2022-01-14T19:05:09.071Z","updatedAt":"2024-09-16T16:28:15.719Z","severity":{"score":7.8,"label":"High","version":"3.0","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"adobe"},"assigner":"adobe","products":["Adobe Acrobat Reader"],"affected":[{"vendor":"Adobe","product":"Acrobat Reader","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"21.007.20099","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"20.004.30017","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"17.011.30204","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":["https://helpx.adobe.com/security/products/acrobat/apsb22-01.html"],"weaknesses":["CWE-787"],"ingestedAt":"2026-10-29T19:49:13.309Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/45xxx/CVE-2021-45068.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-45068","state":"PUBLISHED","datePublished":"2022-01-14T19:05:09.071Z","dateUpdated":"2024-09-16T16:28:15.719Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2021-12-14T00:00:00.000Z"},"containers":{"cna":{"title":"Adobe Acrobat Reader DC Font Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability","descriptions":[{"lang":"en","value":"Acrobat Reader DC version 21.007.20099 (and earlier), 20.004.30017 (and earlier) and 17.011.30204 (and earlier) are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file."}],"affected":[{"vendor":"Adobe","product":"Acrobat Reader","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"21.007.20099","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"20.004.30017","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"17.011.30204","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":[{"url":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_0":{"attackComplexity":"LOW","attackVector":"LOCAL","availabilityImpact":"HIGH","baseScore":7.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-787","description":"Out-of-bounds Write (CWE-787)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2022-01-14T19:05:08.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"datePublic":"2022-01-11T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","DATE_PUBLIC":"2022-01-11T23:00:00.000Z","ID":"CVE-2021-45068","STATE":"PUBLIC","TITLE":"Adobe Acrobat Reader DC Font Parsing Out-Of-Bounds Write Remote Code Execution Vulnerability"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Acrobat Reader","version":{"version_data":[{"version_affected":"<=","version_value":"21.007.20099"},{"version_affected":"<=","version_value":"20.004.30017"},{"version_affected":"<=","version_value":"17.011.30204"},{"version_affected":"<=","version_value":"None"}]}}]},"vendor_name":"Adobe"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Acrobat Reader DC version 21.007.20099 (and earlier), 20.004.30017 (and earlier) and 17.011.30204 (and earlier) are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file."}]},"impact":{"cvss":{"attackComplexity":"Low","attackVector":"Local","availabilityImpact":"High","baseScore":7.8,"baseSeverity":"High","confidentialityImpact":"High","integrityImpact":"High","privilegesRequired":"None","scope":"Unchanged","userInteraction":"Required","vectorString":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Out-of-bounds Write (CWE-787)"}]}]},"references":{"reference_data":[{"name":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html","refsource":"MISC","url":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T04:32:13.525Z"}}]}}}