{"id":"CVE-2021-44709","state":"PUBLISHED","title":"Adobe Acrobat Pro DC Heap Overflow Vulnerability could lead to Arbitrary code execution","description":"Acrobat Reader DC version 21.007.20099 (and earlier), 20.004.30017 (and earlier) and 17.011.30204 (and earlier) are affected by a heap overflow vulnerability due to insecure handling of a crafted file, potentially resulting in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.","publishedAt":"2022-01-14T19:05:10.672Z","updatedAt":"2024-09-16T20:47:24.514Z","severity":{"score":7.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"adobe"},"assigner":"adobe","products":["Adobe Acrobat Reader"],"affected":[{"vendor":"Adobe","product":"Acrobat Reader","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"21.007.20099","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"20.004.30017","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"17.011.30204","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":["https://helpx.adobe.com/security/products/acrobat/apsb22-01.html"],"weaknesses":["CWE-122"],"ingestedAt":"2026-10-29T19:49:10.699Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/44xxx/CVE-2021-44709.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-44709","state":"PUBLISHED","datePublished":"2022-01-14T19:05:10.672Z","dateUpdated":"2024-09-16T20:47:24.514Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2021-12-07T00:00:00.000Z"},"containers":{"cna":{"title":"Adobe Acrobat Pro DC Heap Overflow Vulnerability could lead to Arbitrary code execution","descriptions":[{"lang":"en","value":"Acrobat Reader DC version 21.007.20099 (and earlier), 20.004.30017 (and earlier) and 17.011.30204 (and earlier) are affected by a heap overflow vulnerability due to insecure handling of a crafted file, potentially resulting in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file."}],"affected":[{"vendor":"Adobe","product":"Acrobat Reader","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"21.007.20099","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"20.004.30017","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"17.011.30204","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":[{"url":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"LOCAL","availabilityImpact":"HIGH","baseScore":7.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-122","description":"Heap-based Buffer Overflow (CWE-122)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2022-01-14T19:05:10.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"datePublic":"2022-01-11T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","DATE_PUBLIC":"2022-01-11T23:00:00.000Z","ID":"CVE-2021-44709","STATE":"PUBLIC","TITLE":"Adobe Acrobat Pro DC Heap Overflow Vulnerability could lead to Arbitrary code execution"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Acrobat Reader","version":{"version_data":[{"version_affected":"<=","version_value":"21.007.20099"},{"version_affected":"<=","version_value":"20.004.30017"},{"version_affected":"<=","version_value":"17.011.30204"},{"version_affected":"<=","version_value":"None"}]}}]},"vendor_name":"Adobe"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Acrobat Reader DC version 21.007.20099 (and earlier), 20.004.30017 (and earlier) and 17.011.30204 (and earlier) are affected by a heap overflow vulnerability due to insecure handling of a crafted file, potentially resulting in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file."}]},"impact":{"cvss":{"attackComplexity":"Low","attackVector":"Local","availabilityImpact":"High","baseScore":7.8,"baseSeverity":"High","confidentialityImpact":"High","integrityImpact":"High","privilegesRequired":"None","scope":"Unchanged","userInteraction":"Required","vectorString":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Heap-based Buffer Overflow (CWE-122)"}]}]},"references":{"reference_data":[{"name":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html","refsource":"MISC","url":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://helpx.adobe.com/security/products/acrobat/apsb22-01.html","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T04:25:17.109Z"}}]}}}