{"id":"CVE-2021-44451","state":"PUBLISHED","title":"API sensitive information leak","description":"Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.","publishedAt":"2022-02-01T13:16:32.000Z","updatedAt":"2024-08-04T04:25:16.474Z","severity":null,"assigner":"apache","products":["Apache Software Foundation Apache Superset"],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Superset","versions":[{"version":"Apache Superset","status":"affected","lessThanOrEqual":"1.3.2","versionType":"custom"}]}],"references":["https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb"],"weaknesses":["CWE-522"],"ingestedAt":"2026-10-29T19:49:10.699Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/44xxx/CVE-2021-44451.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-44451","state":"PUBLISHED","datePublished":"2022-02-01T13:16:32.000Z","dateUpdated":"2024-08-04T04:25:16.474Z","assignerShortName":"apache","assignerOrgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateReserved":"2021-11-30T00:00:00.000Z"},"containers":{"cna":{"title":"API sensitive information leak","descriptions":[{"lang":"en","value":"Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher."}],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Superset","versions":[{"version":"Apache Superset","status":"affected","lessThanOrEqual":"1.3.2","versionType":"custom"}]}],"references":[{"url":"https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb","tags":["x_refsource_MISC"]}],"problemTypes":[{"descriptions":[{"cweId":"CWE-522","description":"CWE-522 Insufficiently Protected Credentials","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"apache","dateUpdated":"2022-02-01T13:16:32.000Z","orgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09"},"credits":[{"lang":"en","value":"Found and reported by Cesar Santos"}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@apache.org","ID":"CVE-2021-44451","STATE":"PUBLIC","TITLE":"API sensitive information leak"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Apache Superset","version":{"version_data":[{"version_affected":"<=","version_name":"Apache Superset","version_value":"1.3.2"}]}}]},"vendor_name":"Apache Software Foundation"}]}},"credit":[{"lang":"eng","value":"Found and reported by Cesar Santos"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":[{}],"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-522 Insufficiently Protected Credentials"}]}]},"references":{"reference_data":[{"name":"https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb","refsource":"MISC","url":"https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb"}]},"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T04:25:16.474Z"}}]}}}