{"id":"CVE-2021-4372","state":"PUBLISHED","title":"WooCommerce Dynamic Pricing and Discounts <= 2.4.1 - Stored Cross-Site Scripting","description":"The WooCommerce Dynamic Pricing and Discounts plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.4.1. This is due to missing sanitization on the settings imported via the import() function. This makes it possible for unauthenticated attackers to import a settings file containing malicious JavaScript that would execute when an administrator accesses the settings area of the site.","publishedAt":"2023-06-07T01:51:41.110Z","updatedAt":"2026-04-08T17:18:46.746Z","severity":{"score":6.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["RightPress WooCommerce Dynamic Pricing and Discounts"],"affected":[{"vendor":"RightPress","product":"WooCommerce Dynamic Pricing and Discounts","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2.4.2","versionType":"semver"}]}],"references":["https://www.wordfence.com/threat-intel/vulnerabilities/id/bcaa5d0e-b764-4566-bd46-2d41dc391c36?source=cve","https://blog.nintechnet.com/woocommerce-dynamic-pricing-and-discounts-plugin-fixed-multiple-vulnerabilities/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:49:23.890Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/4xxx/CVE-2021-4372.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2021-4372","state":"PUBLISHED","datePublished":"2023-06-07T01:51:41.110Z","dateUpdated":"2026-04-08T17:18:46.746Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2023-06-06T13:16:06.372Z"},"containers":{"cna":{"title":"WooCommerce Dynamic Pricing and Discounts <= 2.4.1 - Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WooCommerce Dynamic Pricing and Discounts plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.4.1. This is due to missing sanitization on the settings imported via the import() function. This makes it possible for unauthenticated attackers to import a settings file containing malicious JavaScript that would execute when an administrator accesses the settings area of the site."}],"affected":[{"vendor":"RightPress","product":"WooCommerce Dynamic Pricing and Discounts","defaultStatus":"unaffected","versions":[{"version":"0","status":"affected","lessThan":"2.4.2","versionType":"semver"}]}],"references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/bcaa5d0e-b764-4566-bd46-2d41dc391c36?source=cve"},{"url":"https://blog.nintechnet.com/woocommerce-dynamic-pricing-and-discounts-plugin-fixed-multiple-vulnerabilities/"}],"metrics":[{"cvssV3_1":{"version":"3.1","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","baseScore":6.5,"baseSeverity":"MEDIUM"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","lang":"en","description":"CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateUpdated":"2026-04-08T17:18:46.746Z"},"credits":[{"lang":"en","type":"finder","value":"Jerome Bruandet"}],"timeline":[{"time":"2021-08-31T00:00:00.000Z","lang":"en","value":"Disclosed"}]},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/threat-intel/vulnerabilities/id/bcaa5d0e-b764-4566-bd46-2d41dc391c36?source=cve","tags":["x_transferred"]},{"url":"https://blog.nintechnet.com/woocommerce-dynamic-pricing-and-discounts-plugin-fixed-multiple-vulnerabilities/","tags":["x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T17:23:10.738Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2024-12-28T00:40:38.096735Z","id":"CVE-2021-4372","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2024-12-28T00:53:48.474Z"}}]}}}