{"id":"CVE-2021-41836","state":"PUBLISHED","title":"Fathom Analytics <= 3.0.4 Authenticated Stored Cross-Site Scripting","description":"The Fathom Analytics WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and escaping via the $site_id parameter found in the ~/fathom-analytics.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 3.0.4. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.","publishedAt":"2021-12-14T15:50:10.933Z","updatedAt":"2025-02-10T14:55:13.698Z","severity":{"score":4.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["Fathom Analytics Fathom Analytics"],"affected":[{"vendor":"Fathom Analytics","product":"Fathom Analytics","versions":[{"version":"3.0.4","status":"affected","lessThanOrEqual":"3.0.4","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-41836","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2641005%40fathom-analytics&new=2641005%40fathom-analytics&sfp_email=&sfph_mail="],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:49:01.697Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/41xxx/CVE-2021-41836.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-41836","state":"PUBLISHED","datePublished":"2021-12-14T15:50:10.933Z","dateUpdated":"2025-02-10T14:55:13.698Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-12-03T00:00:00.000Z"},"containers":{"cna":{"title":"Fathom Analytics <= 3.0.4 Authenticated Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Fathom Analytics WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and escaping via the $site_id parameter found in the ~/fathom-analytics.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 3.0.4. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled."}],"affected":[{"vendor":"Fathom Analytics","product":"Fathom Analytics","versions":[{"version":"3.0.4","status":"affected","lessThanOrEqual":"3.0.4","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-41836","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2641005%40fathom-analytics&new=2641005%40fathom-analytics&sfp_email=&sfph_mail=","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-12-14T15:50:10.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"José Aguilera"}],"datePublic":"2021-12-08T00:00:00.000Z","solutions":[{"lang":"en","value":"Update to version 3.0.5, or newer."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-12-08T13:23:00.000Z","ID":"CVE-2021-41836","STATE":"PUBLIC","TITLE":"Fathom Analytics <= 3.0.4 Authenticated Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Fathom Analytics","version":{"version_data":[{"version_affected":"<=","version_name":"3.0.4","version_value":"3.0.4"}]}}]},"vendor_name":"Fathom Analytics"}]}},"credit":[{"lang":"eng","value":"José Aguilera"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Fathom Analytics WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and escaping via the $site_id parameter found in the ~/fathom-analytics.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 3.0.4. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-41836","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-41836"},{"name":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2641005%40fathom-analytics&new=2641005%40fathom-analytics&sfp_email=&sfph_mail=","refsource":"MISC","url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2641005%40fathom-analytics&new=2641005%40fathom-analytics&sfp_email=&sfph_mail="}]},"solution":[{"lang":"en","value":"Update to version 3.0.5, or newer."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-41836","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2641005%40fathom-analytics&new=2641005%40fathom-analytics&sfp_email=&sfph_mail=","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T03:22:24.913Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-10T14:55:07.639655Z","id":"CVE-2021-41836","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-10T14:55:13.698Z"}}]}}}