{"id":"CVE-2021-41264","state":"PUBLISHED","title":"UUPSUpgradeable vulnerability in OpenZeppelin Contracts","description":"OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).","publishedAt":"2021-11-12T17:55:11.000Z","updatedAt":"2024-08-04T03:08:31.576Z","severity":{"score":9.8,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","source":"GitHub_M"},"assigner":"GitHub_M","products":["OpenZeppelin openzeppelin-contracts"],"affected":[{"vendor":"OpenZeppelin","product":"openzeppelin-contracts","versions":[{"version":">= 4.1.0 < 4.3.2","status":"affected"}]}],"references":["https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76","https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592","https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301"],"weaknesses":["CWE-665"],"ingestedAt":"2026-10-29T19:49:01.697Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/41xxx/CVE-2021-41264.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-41264","state":"PUBLISHED","datePublished":"2021-11-12T17:55:11.000Z","dateUpdated":"2024-08-04T03:08:31.576Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2021-09-15T00:00:00.000Z"},"containers":{"cna":{"title":"UUPSUpgradeable vulnerability in OpenZeppelin Contracts","descriptions":[{"lang":"en","value":"OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301)."}],"affected":[{"vendor":"OpenZeppelin","product":"openzeppelin-contracts","versions":[{"version":">= 4.1.0 < 4.3.2","status":"affected"}]}],"references":[{"url":"https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592","tags":["x_refsource_MISC"]},{"url":"https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9.8,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-665","description":"CWE-665: Improper Initialization","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2021-11-12T17:55:11.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-5vp3-v4hc-gx76","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2021-41264","STATE":"PUBLIC","TITLE":"UUPSUpgradeable vulnerability in OpenZeppelin Contracts"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"openzeppelin-contracts","version":{"version_data":[{"version_value":">= 4.1.0 < 4.3.2"}]}}]},"vendor_name":"OpenZeppelin"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301)."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9.8,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-665: Improper Initialization"}]}]},"references":{"reference_data":[{"name":"https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76","refsource":"CONFIRM","url":"https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76"},{"name":"https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592","refsource":"MISC","url":"https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592"},{"name":"https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301","refsource":"MISC","url":"https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301"}]},"source":{"advisory":"GHSA-5vp3-v4hc-gx76","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T03:08:31.576Z"}}]}}}