{"id":"CVE-2021-4074","state":"PUBLISHED","title":"WHMCS Bridge <= 6.1 Subscriber+ Stored Cross-Site Scripting","description":"The WHMCS Bridge WordPress plugin is vulnerable to Stored Cross-Site Scripting via the cc_whmcs_bridge_url parameter found in the ~/whmcs-bridge/bridge_cp.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 6.1. Due to missing authorization checks on the cc_whmcs_bridge_add_admin function, low-level authenticated users such as subscribers can exploit this vulnerability.","publishedAt":"2022-01-18T16:52:27.000Z","updatedAt":"2025-02-14T17:47:58.874Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["WHMCS Bridge WHMCS Bridge"],"affected":[{"vendor":"WHMCS Bridge","product":"WHMCS Bridge","versions":[{"version":"6.1","status":"affected","lessThanOrEqual":"6.1","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-4074","https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2653041%40whmcs-bridge&new=2653041%40whmcs-bridge&sfp_email=&sfph_mail="],"weaknesses":["CWE-79","CWE-862"],"ingestedAt":"2026-10-29T19:49:23.890Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/4xxx/CVE-2021-4074.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-4074","state":"PUBLISHED","datePublished":"2022-01-18T16:52:27.000Z","dateUpdated":"2025-02-14T17:47:58.874Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-12-06T00:00:00.000Z"},"containers":{"cna":{"title":"WHMCS Bridge <= 6.1 Subscriber+ Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WHMCS Bridge WordPress plugin is vulnerable to Stored Cross-Site Scripting via the cc_whmcs_bridge_url parameter found in the ~/whmcs-bridge/bridge_cp.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 6.1. Due to missing authorization checks on the cc_whmcs_bridge_add_admin function, low-level authenticated users such as subscribers can exploit this vulnerability."}],"affected":[{"vendor":"WHMCS Bridge","product":"WHMCS Bridge","versions":[{"version":"6.1","status":"affected","lessThanOrEqual":"6.1","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-4074","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2653041%40whmcs-bridge&new=2653041%40whmcs-bridge&sfp_email=&sfph_mail=","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-862","description":"CWE-862 Missing Authorization","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2022-01-18T16:52:27.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Kazuto Kokonoe, Tokyo Denki University Cryptography Laboratory"}],"solutions":[{"lang":"en","value":"Update to version 6.3, or newer. "}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","ID":"CVE-2021-4074","STATE":"PUBLIC","TITLE":"WHMCS Bridge <= 6.1 Subscriber+ Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WHMCS Bridge","version":{"version_data":[{"version_affected":"<=","version_name":"6.1","version_value":"6.1"}]}}]},"vendor_name":"WHMCS Bridge"}]}},"credit":[{"lang":"eng","value":"Kazuto Kokonoe, Tokyo Denki University Cryptography Laboratory"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WHMCS Bridge WordPress plugin is vulnerable to Stored Cross-Site Scripting via the cc_whmcs_bridge_url parameter found in the ~/whmcs-bridge/bridge_cp.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 6.1. Due to missing authorization checks on the cc_whmcs_bridge_add_admin function, low-level authenticated users such as subscribers can exploit this vulnerability."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.4,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"LOW","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]},{"description":[{"lang":"eng","value":"CWE-862 Missing Authorization"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-4074","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-4074"},{"name":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2653041%40whmcs-bridge&new=2653041%40whmcs-bridge&sfp_email=&sfph_mail=","refsource":"MISC","url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2653041%40whmcs-bridge&new=2653041%40whmcs-bridge&sfp_email=&sfph_mail="}]},"solution":[{"lang":"en","value":"Update to version 6.3, or newer. "}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-4074","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2653041%40whmcs-bridge&new=2653041%40whmcs-bridge&sfp_email=&sfph_mail=","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T17:16:03.778Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-14T17:47:48.876682Z","id":"CVE-2021-4074","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-14T17:47:58.874Z"}}]}}}