{"id":"CVE-2021-39346","state":"PUBLISHED","title":"Google Maps Easy <= 1.9.33 Authenticated Stored Cross-Site Scripting","description":"The Google Maps Easy WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.9.33. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.","publishedAt":"2021-11-01T20:59:29.030Z","updatedAt":"2025-03-31T17:47:24.024Z","severity":{"score":4.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["Google Maps Easy Google Maps Easy"],"affected":[{"vendor":"Google Maps Easy","product":"Google Maps Easy","versions":[{"version":"1.9.33","status":"affected","lessThanOrEqual":"1.9.33","versionType":"custom"}]}],"references":["https://github.com/BigTiger2020/word-press/blob/main/Google%20Maps%20Easy.md","https://plugins.trac.wordpress.org/changeset/2620851/google-maps-easy/trunk/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php","https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39346"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:52.666Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/39xxx/CVE-2021-39346.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-39346","state":"PUBLISHED","datePublished":"2021-11-01T20:59:29.030Z","dateUpdated":"2025-03-31T17:47:24.024Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-08-20T00:00:00.000Z"},"containers":{"cna":{"title":"Google Maps Easy <= 1.9.33 Authenticated Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Google Maps Easy WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.9.33. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled."}],"affected":[{"vendor":"Google Maps Easy","product":"Google Maps Easy","versions":[{"version":"1.9.33","status":"affected","lessThanOrEqual":"1.9.33","versionType":"custom"}]}],"references":[{"url":"https://github.com/BigTiger2020/word-press/blob/main/Google%20Maps%20Easy.md","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/changeset/2620851/google-maps-easy/trunk/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php","tags":["x_refsource_MISC"]},{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39346","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-11-01T20:59:29.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Thinkland Security Team"}],"datePublic":"2021-11-01T00:00:00.000Z","solutions":[{"lang":"en","value":"Update to version 1.10.1 or newer."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-11-01T10:32:00.000Z","ID":"CVE-2021-39346","STATE":"PUBLIC","TITLE":"Google Maps Easy <= 1.9.33 Authenticated Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Google Maps Easy","version":{"version_data":[{"version_affected":"<=","version_name":"1.9.33","version_value":"1.9.33"}]}}]},"vendor_name":"Google Maps Easy"}]}},"credit":[{"lang":"eng","value":"Thinkland Security Team"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Google Maps Easy WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 1.9.33. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://github.com/BigTiger2020/word-press/blob/main/Google%20Maps%20Easy.md","refsource":"MISC","url":"https://github.com/BigTiger2020/word-press/blob/main/Google%20Maps%20Easy.md"},{"name":"https://plugins.trac.wordpress.org/changeset/2620851/google-maps-easy/trunk/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php","refsource":"MISC","url":"https://plugins.trac.wordpress.org/changeset/2620851/google-maps-easy/trunk/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php"},{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39346","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39346"}]},"solution":[{"lang":"en","value":"Update to version 1.10.1 or newer."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/BigTiger2020/word-press/blob/main/Google%20Maps%20Easy.md","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/changeset/2620851/google-maps-easy/trunk/modules/marker_groups/views/tpl/mgrEditMarkerGroup.php","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39346","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T02:06:42.445Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-31T17:47:17.685321Z","id":"CVE-2021-39346","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-31T17:47:24.024Z"}}]}}}