{"id":"CVE-2021-39344","state":"PUBLISHED","title":"KJM Admin Notices <= 2.0.1 Authenticated Stored Cross-Site Scripting","description":"The KJM Admin Notices WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/admin/class-kjm-admin-notices-admin.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 2.0.1. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled.","publishedAt":"2021-10-15T12:15:52.829Z","updatedAt":"2025-02-14T17:56:29.997Z","severity":{"score":5.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["KJM Admin Notices KJM Admin Notices"],"affected":[{"vendor":"KJM Admin Notices","product":"KJM Admin Notices","versions":[{"version":"2.0.1","status":"affected","lessThanOrEqual":"2.0.1","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39344","https://github.com/BigTiger2020/word-press/blob/main/KJM%20Admin%20Notices.md","https://plugins.trac.wordpress.org/browser/kjm-admin-notices/trunk/admin/class-kjm-admin-notices-admin.php"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:52.666Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/39xxx/CVE-2021-39344.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-39344","state":"PUBLISHED","datePublished":"2021-10-15T12:15:52.829Z","dateUpdated":"2025-02-14T17:56:29.997Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-08-20T00:00:00.000Z"},"containers":{"cna":{"title":"KJM Admin Notices <= 2.0.1 Authenticated Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The KJM Admin Notices WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/admin/class-kjm-admin-notices-admin.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 2.0.1. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled."}],"affected":[{"vendor":"KJM Admin Notices","product":"KJM Admin Notices","versions":[{"version":"2.0.1","status":"affected","lessThanOrEqual":"2.0.1","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39344","tags":["x_refsource_MISC"]},{"url":"https://github.com/BigTiger2020/word-press/blob/main/KJM%20Admin%20Notices.md","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/browser/kjm-admin-notices/trunk/admin/class-kjm-admin-notices-admin.php","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-10-15T12:15:52.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Thinkland Security Team"}],"datePublic":"2021-10-14T00:00:00.000Z","solutions":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-10-14T13:46:00.000Z","ID":"CVE-2021-39344","STATE":"PUBLIC","TITLE":"KJM Admin Notices <= 2.0.1 Authenticated Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"KJM Admin Notices","version":{"version_data":[{"version_affected":"<=","version_name":"2.0.1","version_value":"2.0.1"}]}}]},"vendor_name":"KJM Admin Notices"}]}},"credit":[{"lang":"eng","value":"Thinkland Security Team"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The KJM Admin Notices WordPress plugin is vulnerable to Stored Cross-Site Scripting due to insufficient input validation and sanitization via several parameters found in the ~/admin/class-kjm-admin-notices-admin.php file which allowed attackers with administrative user access to inject arbitrary web scripts, in versions up to and including 2.0.1. This affects multi-site installations where unfiltered_html is disabled for administrators, and sites where unfiltered_html is disabled."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39344","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39344"},{"name":"https://github.com/BigTiger2020/word-press/blob/main/KJM%20Admin%20Notices.md","refsource":"MISC","url":"https://github.com/BigTiger2020/word-press/blob/main/KJM%20Admin%20Notices.md"},{"name":"https://plugins.trac.wordpress.org/browser/kjm-admin-notices/trunk/admin/class-kjm-admin-notices-admin.php","refsource":"MISC","url":"https://plugins.trac.wordpress.org/browser/kjm-admin-notices/trunk/admin/class-kjm-admin-notices-admin.php"}]},"solution":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39344","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://github.com/BigTiger2020/word-press/blob/main/KJM%20Admin%20Notices.md","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/kjm-admin-notices/trunk/admin/class-kjm-admin-notices-admin.php","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T02:06:42.479Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-14T17:56:25.499332Z","id":"CVE-2021-39344","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-14T17:56:29.997Z"}}]}}}