{"id":"CVE-2021-39341","state":"PUBLISHED","title":"OptinMonster <= 2.6.4 Unprotected REST-API Endpoints","description":"The OptinMonster WordPress plugin is vulnerable to sensitive information disclosure and unauthorized setting updates due to insufficient authorization validation via the logged_in_or_has_api_key function in the ~/OMAPI/RestApi.php file that can used to exploit inject malicious web scripts on sites with the plugin installed. This affects versions up to, and including, 2.6.4.","publishedAt":"2021-11-01T21:01:23.439Z","updatedAt":"2025-03-31T17:45:22.682Z","severity":{"score":8.2,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["OptinMonster OptinMonster"],"affected":[{"vendor":"OptinMonster","product":"OptinMonster","versions":[{"version":"2.6.4","status":"affected","lessThanOrEqual":"2.6.4","versionType":"custom"}]}],"references":["https://www.wordfence.com/blog/2021/10/1000000-sites-affected-by-optinmonster-vulnerabilities/","https://wordfence.com/vulnerability-advisories/#CVE-2021-39341","https://plugins.trac.wordpress.org/browser/optinmonster/trunk/OMAPI/RestApi.php?rev=2606519#L1460"],"weaknesses":["CWE-285","CWE-319"],"ingestedAt":"2026-10-29T19:48:52.666Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/39xxx/CVE-2021-39341.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-39341","state":"PUBLISHED","datePublished":"2021-11-01T21:01:23.439Z","dateUpdated":"2025-03-31T17:45:22.682Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-08-20T00:00:00.000Z"},"containers":{"cna":{"title":"OptinMonster <= 2.6.4 Unprotected REST-API Endpoints","descriptions":[{"lang":"en","value":"The OptinMonster WordPress plugin is vulnerable to sensitive information disclosure and unauthorized setting updates due to insufficient authorization validation via the logged_in_or_has_api_key function in the ~/OMAPI/RestApi.php file that can used to exploit inject malicious web scripts on sites with the plugin installed. This affects versions up to, and including, 2.6.4."}],"affected":[{"vendor":"OptinMonster","product":"OptinMonster","versions":[{"version":"2.6.4","status":"affected","lessThanOrEqual":"2.6.4","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/blog/2021/10/1000000-sites-affected-by-optinmonster-vulnerabilities/","tags":["x_refsource_MISC"]},{"url":"https://wordfence.com/vulnerability-advisories/#CVE-2021-39341","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/browser/optinmonster/trunk/OMAPI/RestApi.php?rev=2606519#L1460","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":8.2,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-285","description":"CWE-285 Improper Authorization","lang":"en","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-319","description":"CWE-319 Cleartext Transmission of Sensitive Information","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-11-01T21:01:23.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Chloe Chamberland, Wordfence"}],"datePublic":"2021-11-01T00:00:00.000Z","solutions":[{"lang":"en","value":"Update to version 2.6.5, or newer."}],"source":{"discovery":"UNKNOWN"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-11-01T09:02:00.000Z","ID":"CVE-2021-39341","STATE":"PUBLIC","TITLE":"OptinMonster <= 2.6.4 Unprotected REST-API Endpoints"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"OptinMonster","version":{"version_data":[{"version_affected":"<=","version_name":"2.6.4","version_value":"2.6.4"}]}}]},"vendor_name":"OptinMonster"}]}},"credit":[{"lang":"eng","value":"Chloe Chamberland, Wordfence"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The OptinMonster WordPress plugin is vulnerable to sensitive information disclosure and unauthorized setting updates due to insufficient authorization validation via the logged_in_or_has_api_key function in the ~/OMAPI/RestApi.php file that can used to exploit inject malicious web scripts on sites with the plugin installed. This affects versions up to, and including, 2.6.4."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":8.2,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-285 Improper Authorization"}]},{"description":[{"lang":"eng","value":"CWE-319 Cleartext Transmission of Sensitive Information"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/blog/2021/10/1000000-sites-affected-by-optinmonster-vulnerabilities/","refsource":"MISC","url":"https://www.wordfence.com/blog/2021/10/1000000-sites-affected-by-optinmonster-vulnerabilities/"},{"name":"https://wordfence.com/vulnerability-advisories/#CVE-2021-39341","refsource":"MISC","url":"https://wordfence.com/vulnerability-advisories/#CVE-2021-39341"},{"name":"https://plugins.trac.wordpress.org/browser/optinmonster/trunk/OMAPI/RestApi.php?rev=2606519#L1460","refsource":"MISC","url":"https://plugins.trac.wordpress.org/browser/optinmonster/trunk/OMAPI/RestApi.php?rev=2606519#L1460"}]},"solution":[{"lang":"en","value":"Update to version 2.6.5, or newer."}],"source":{"discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/blog/2021/10/1000000-sites-affected-by-optinmonster-vulnerabilities/","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://wordfence.com/vulnerability-advisories/#CVE-2021-39341","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/optinmonster/trunk/OMAPI/RestApi.php?rev=2606519#L1460","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T02:06:42.512Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-31T17:45:12.515792Z","id":"CVE-2021-39341","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-31T17:45:22.682Z"}}]}}}