{"id":"CVE-2021-39315","state":"PUBLISHED","title":"Magic Post Voice <= 1.2 Reflected Cross-Site Scripting","description":"The Magic Post Voice WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the ids parameter found in the ~/inc/admin/main.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.2.","publishedAt":"2021-12-14T15:50:08.501Z","updatedAt":"2025-02-13T20:48:08.572Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["Magic Post Voice Magic Post Voice"],"affected":[{"vendor":"Magic Post Voice","product":"Magic Post Voice","versions":[{"version":"1.2","status":"affected","lessThanOrEqual":"1.2","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39315","https://plugins.trac.wordpress.org/browser/magic-post-voice/trunk/inc/admin/main.php#L14"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:52.666Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/39xxx/CVE-2021-39315.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-39315","state":"PUBLISHED","datePublished":"2021-12-14T15:50:08.501Z","dateUpdated":"2025-02-13T20:48:08.572Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-08-20T00:00:00.000Z"},"containers":{"cna":{"title":"Magic Post Voice <= 1.2 Reflected Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Magic Post Voice WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the ids parameter found in the ~/inc/admin/main.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.2."}],"affected":[{"vendor":"Magic Post Voice","product":"Magic Post Voice","versions":[{"version":"1.2","status":"affected","lessThanOrEqual":"1.2","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39315","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/browser/magic-post-voice/trunk/inc/admin/main.php#L14","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.1,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-12-14T15:50:08.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"p7e4"}],"datePublic":"2021-12-13T00:00:00.000Z","solutions":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-12-13T12:43:00.000Z","ID":"CVE-2021-39315","STATE":"PUBLIC","TITLE":"Magic Post Voice <= 1.2 Reflected Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Magic Post Voice","version":{"version_data":[{"version_affected":"<=","version_name":"1.2","version_value":"1.2"}]}}]},"vendor_name":"Magic Post Voice"}]}},"credit":[{"lang":"eng","value":"p7e4"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Magic Post Voice WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the ids parameter found in the ~/inc/admin/main.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.2."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.1,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39315","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39315"},{"name":"https://plugins.trac.wordpress.org/browser/magic-post-voice/trunk/inc/admin/main.php#L14","refsource":"MISC","url":"https://plugins.trac.wordpress.org/browser/magic-post-voice/trunk/inc/admin/main.php#L14"}]},"solution":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-39315","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/magic-post-voice/trunk/inc/admin/main.php#L14","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T02:06:41.730Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-13T20:48:02.165895Z","id":"CVE-2021-39315","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-13T20:48:08.572Z"}}]}}}