{"id":"CVE-2021-38345","state":"PUBLISHED","title":"Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification","description":"The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127.","publishedAt":"2021-10-14T15:56:51.848Z","updatedAt":"2025-02-14T18:11:40.173Z","severity":{"score":7.1,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L","source":"Wordfence"},"assigner":"Wordfence","products":["Brizy.io Brizy - Page Builder"],"affected":[{"vendor":"Brizy.io","product":"Brizy - Page Builder","versions":[{"version":"2.3.11","status":"affected","lessThanOrEqual":"2.3.11","versionType":"custom"},{"version":"1.0.127","status":"affected","lessThan":"1.0.127*","versionType":"custom"},{"version":"1.0.125","status":"affected","lessThanOrEqual":"1.0.125","versionType":"custom"}],"platforms":["WordPress"]}],"references":["https://www.wordfence.com/blog/2021/10/multiple-vulnerabilities-in-brizy-page-builder-plugin-allow-site-takeover/"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:49.871Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/38xxx/CVE-2021-38345.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-38345","state":"PUBLISHED","datePublished":"2021-10-14T15:56:51.848Z","dateUpdated":"2025-02-14T18:11:40.173Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-08-09T00:00:00.000Z"},"containers":{"cna":{"title":"Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification","descriptions":[{"lang":"en","value":"The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127."}],"affected":[{"vendor":"Brizy.io","product":"Brizy - Page Builder","versions":[{"version":"2.3.11","status":"affected","lessThanOrEqual":"2.3.11","versionType":"custom"},{"version":"1.0.127","status":"affected","lessThan":"1.0.127*","versionType":"custom"},{"version":"1.0.125","status":"affected","lessThanOrEqual":"1.0.125","versionType":"custom"}],"platforms":["WordPress"]}],"references":[{"url":"https://www.wordfence.com/blog/2021/10/multiple-vulnerabilities-in-brizy-page-builder-plugin-allow-site-takeover/","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":7.1,"baseSeverity":"HIGH","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-10-14T15:56:51.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Ramuel Gall, Wordfence"}],"datePublic":"2021-10-13T00:00:00.000Z","source":{"discovery":"INTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-10-13T00:00:00.000Z","ID":"CVE-2021-38345","STATE":"PUBLIC","TITLE":"Brizy <= 1.0.125 and 1.0.127 – 2.3.11 Incorrect authorization checks allowing Post modification"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Brizy - Page Builder","version":{"version_data":[{"platform":"WordPress","version_affected":"<=","version_name":"2.3.11","version_value":"2.3.11"},{"platform":"WordPress","version_affected":">=","version_name":"1.0.127","version_value":"1.0.127"},{"platform":"WordPress","version_affected":"<=","version_name":"1.0.125","version_value":"1.0.125"}]}}]},"vendor_name":"Brizy.io"}]}},"credit":[{"lang":"eng","value":"Ramuel Gall, Wordfence"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Brizy Page Builder plugin <= 2.3.11 for WordPress used an incorrect authorization check that allowed any logged-in user accessing any endpoint in the wp-admin directory to modify the content of any existing post or page created with the Brizy editor. An identical issue was found by another researcher in Brizy <= 1.0.125 and fixed in version 1.0.126, but the vulnerability was reintroduced in version 1.0.127."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":7.1,"baseSeverity":"HIGH","confidentialityImpact":"NONE","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/blog/2021/10/multiple-vulnerabilities-in-brizy-page-builder-plugin-allow-site-takeover/","refsource":"MISC","url":"https://www.wordfence.com/blog/2021/10/multiple-vulnerabilities-in-brizy-page-builder-plugin-allow-site-takeover/"}]},"source":{"discovery":"INTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/blog/2021/10/multiple-vulnerabilities-in-brizy-page-builder-plugin-allow-site-takeover/","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T01:37:16.512Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-14T18:11:32.272525Z","id":"CVE-2021-38345","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-14T18:11:40.173Z"}}]}}}