{"id":"CVE-2021-38316","state":"PUBLISHED","title":"WP Academic People List <= 0.4.1 Reflected Cross-Site Scripting","description":"The WP Academic People List WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the category_name parameter in the ~/admin-panel.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 0.4.1.","publishedAt":"2021-09-09T18:09:41.799Z","updatedAt":"2025-05-05T18:14:49.822Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["WP Academic People List WP Academic People List"],"affected":[{"vendor":"WP Academic People List","product":"WP Academic People List","versions":[{"version":"0.4.1","status":"affected","lessThanOrEqual":"0.4.1","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-38316","https://plugins.trac.wordpress.org/browser/wp-academic-people/tags/0.4.1/admin-panel.php#L57"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:49.871Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/38xxx/CVE-2021-38316.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-38316","state":"PUBLISHED","datePublished":"2021-09-09T18:09:41.799Z","dateUpdated":"2025-05-05T18:14:49.822Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-08-09T00:00:00.000Z"},"containers":{"cna":{"title":"WP Academic People List <= 0.4.1 Reflected Cross-Site Scripting","descriptions":[{"lang":"en","value":"The WP Academic People List WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the category_name parameter in the ~/admin-panel.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 0.4.1."}],"affected":[{"vendor":"WP Academic People List","product":"WP Academic People List","versions":[{"version":"0.4.1","status":"affected","lessThanOrEqual":"0.4.1","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-38316","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/browser/wp-academic-people/tags/0.4.1/admin-panel.php#L57","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.1,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-09-09T18:09:41.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"p7e4"}],"datePublic":"2021-09-08T00:00:00.000Z","solutions":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-09-08T17:23:00.000Z","ID":"CVE-2021-38316","STATE":"PUBLIC","TITLE":"WP Academic People List <= 0.4.1 Reflected Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP Academic People List","version":{"version_data":[{"version_affected":"<=","version_name":"0.4.1","version_value":"0.4.1"}]}}]},"vendor_name":"WP Academic People List"}]}},"credit":[{"lang":"eng","value":"p7e4"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The WP Academic People List WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the category_name parameter in the ~/admin-panel.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 0.4.1."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.1,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-38316","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-38316"},{"name":"https://plugins.trac.wordpress.org/browser/wp-academic-people/tags/0.4.1/admin-panel.php#L57","refsource":"MISC","url":"https://plugins.trac.wordpress.org/browser/wp-academic-people/tags/0.4.1/admin-panel.php#L57"}]},"solution":[{"lang":"en","value":"Uninstall plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-38316","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/wp-academic-people/tags/0.4.1/admin-panel.php#L57","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T01:37:16.287Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-05-05T18:14:39.990979Z","id":"CVE-2021-38316","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-05T18:14:49.822Z"}}]}}}