{"id":"CVE-2021-37633","state":"PUBLISHED","title":"XSS via d-popover and d-html-popover attribute","description":"Discourse is an open source discussion platform. In versions prior to 2.7.8 rendering of d-popover tooltips can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. This issue is patched in the latest `stable` 2.7.8 version of Discourse. As a workaround users may ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks.","publishedAt":"2021-08-09T19:35:09.000Z","updatedAt":"2024-08-04T01:23:01.396Z","severity":{"score":7.4,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["discourse discourse"],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":"< 2.7.8","status":"affected"}]}],"references":["https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9","https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:47.122Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/37xxx/CVE-2021-37633.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-37633","state":"PUBLISHED","datePublished":"2021-08-09T19:35:09.000Z","dateUpdated":"2024-08-04T01:23:01.396Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2021-07-29T00:00:00.000Z"},"containers":{"cna":{"title":"XSS via d-popover and d-html-popover attribute","descriptions":[{"lang":"en","value":"Discourse is an open source discussion platform. In versions prior to 2.7.8 rendering of d-popover tooltips can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. This issue is patched in the latest `stable` 2.7.8 version of Discourse. As a workaround users may ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks."}],"affected":[{"vendor":"discourse","product":"discourse","versions":[{"version":"< 2.7.8","status":"affected"}]}],"references":[{"url":"https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":7.4,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2021-08-09T19:35:09.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-v3v8-3m5w-pjp9","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2021-37633","STATE":"PUBLIC","TITLE":"XSS via d-popover and d-html-popover attribute"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"discourse","version":{"version_data":[{"version_value":"< 2.7.8"}]}}]},"vendor_name":"discourse"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Discourse is an open source discussion platform. In versions prior to 2.7.8 rendering of d-popover tooltips can be susceptible to XSS attacks. This vulnerability only affects sites which have modified or disabled Discourse's default Content Security Policy. This issue is patched in the latest `stable` 2.7.8 version of Discourse. As a workaround users may ensure that the Content Security Policy is enabled, and has not been modified in a way which would make it more vulnerable to XSS attacks."}]},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":7.4,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}]},"references":{"reference_data":[{"name":"https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9","refsource":"CONFIRM","url":"https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9"},{"name":"https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47","refsource":"MISC","url":"https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47"}]},"source":{"advisory":"GHSA-v3v8-3m5w-pjp9","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/discourse/discourse/security/advisories/GHSA-v3v8-3m5w-pjp9","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/discourse/discourse/commit/38199424bc840d2ef002cd1e9bffdbb99191eb47","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T01:23:01.396Z"}}]}}}