{"id":"CVE-2021-36896","state":"PUBLISHED","title":"WordPress Pricing Table plugin <= 1.5.2 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability","description":"Authenticated (author or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in Pricing Table (WordPress plugin) versions <= 1.5.2","publishedAt":"2022-04-11T19:36:57.094Z","updatedAt":"2026-04-28T16:07:36.526Z","severity":{"score":4.8,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","source":"Patchstack"},"assigner":"Patchstack","products":["W3 Eden, Inc. Pricing Table (WordPress plugin)"],"affected":[{"vendor":"W3 Eden, Inc.","product":"Pricing Table (WordPress plugin)","versions":[{"version":"<= 1.5.2","status":"affected","lessThanOrEqual":"1.5.2","versionType":"custom"}]}],"references":["https://wordpress.org/plugins/pricing-table/#developers","https://patchstack.com/database/vulnerability/pricing-table/wordpress-pricing-table-plugin-1-5-2-authenticated-stored-cross-site-scripting-xss-vulnerability"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:44.655Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/36xxx/CVE-2021-36896.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2021-36896","state":"PUBLISHED","datePublished":"2022-04-11T19:36:57.094Z","dateUpdated":"2026-04-28T16:07:36.526Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2021-07-19T00:00:00.000Z"},"containers":{"cna":{"title":"WordPress Pricing Table plugin <= 1.5.2 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability","descriptions":[{"lang":"en","value":"Authenticated (author or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in Pricing Table (WordPress plugin) versions <= 1.5.2"}],"affected":[{"vendor":"W3 Eden, Inc.","product":"Pricing Table (WordPress plugin)","versions":[{"version":"<= 1.5.2","status":"affected","lessThanOrEqual":"1.5.2","versionType":"custom"}]}],"references":[{"url":"https://wordpress.org/plugins/pricing-table/#developers","tags":["x_refsource_CONFIRM"]},{"url":"https://patchstack.com/database/vulnerability/pricing-table/wordpress-pricing-table-plugin-1-5-2-authenticated-stored-cross-site-scripting-xss-vulnerability","tags":["x_refsource_CONFIRM"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:07:36.526Z"},"credits":[{"lang":"en","value":"Vulnerability discovered by Ngo Van Thien (Patchstack Alliance)"}],"datePublic":"2022-04-05T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"audit@patchstack.com","DATE_PUBLIC":"2022-04-05T14:36:00.000Z","ID":"CVE-2021-36896","STATE":"PUBLIC","TITLE":"WordPress Pricing Table plugin <= 1.5.2 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Pricing Table (WordPress plugin)","version":{"version_data":[{"version_affected":"<=","version_name":"<= 1.5.2","version_value":"1.5.2"}]}}]},"vendor_name":"W3 Eden, Inc."}]}},"credit":[{"lang":"eng","value":"Vulnerability discovered by Ngo Van Thien (Patchstack Alliance)"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Authenticated (author or higher user role) Stored Cross-Site Scripting (XSS) vulnerability in Pricing Table (WordPress plugin) versions <= 1.5.2"}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":4.8,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://wordpress.org/plugins/pricing-table/#developers","refsource":"CONFIRM","url":"https://wordpress.org/plugins/pricing-table/#developers"},{"name":"https://patchstack.com/database/vulnerability/pricing-table/wordpress-pricing-table-plugin-1-5-2-authenticated-stored-cross-site-scripting-xss-vulnerability","refsource":"CONFIRM","url":"https://patchstack.com/database/vulnerability/pricing-table/wordpress-pricing-table-plugin-1-5-2-authenticated-stored-cross-site-scripting-xss-vulnerability"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://wordpress.org/plugins/pricing-table/#developers","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://patchstack.com/database/vulnerability/pricing-table/wordpress-pricing-table-plugin-1-5-2-authenticated-stored-cross-site-scripting-xss-vulnerability","tags":["x_refsource_CONFIRM","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T01:01:59.769Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-02-20T19:32:07.052122Z","id":"CVE-2021-36896","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-02-20T20:28:20.605Z"}}]}}}