{"id":"CVE-2021-36871","state":"PUBLISHED","title":"WordPress WP Google Maps Pro premium plugin <= 8.1.11 - Multiple Authenticated Persistent XSS vulnerabilities","description":"Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities in WordPress WP Google Maps Pro premium plugin (versions <= 8.1.11). Vulnerable parameters: &wpgmaps_marker_category_name, Value > &attributes[], Name > &attributes[], &icons[], &names[], &description, &link, &title.","publishedAt":"2021-09-09T11:19:51.696Z","updatedAt":"2026-04-28T16:07:36.029Z","severity":{"score":5.5,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","source":"Patchstack"},"assigner":"Patchstack","products":["Code Cabin Inc WP Google Maps Pro"],"affected":[{"vendor":"Code Cabin Inc","product":"WP Google Maps Pro","versions":[{"version":"8.1.11","status":"affected","lessThanOrEqual":"8.1.11","versionType":"custom"}]}],"references":["https://www.wpgmaps.com/documentation/pro-changelog/","https://patchstack.com/database/vulnerability/wp-google-maps-pro/wordpress-wp-google-maps-pro-premium-plugin-8-1-11-multiple-authenticated-persistent-cross-site-scripting-xss-vulnerabilities"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:44.655Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/36xxx/CVE-2021-36871.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2021-36871","state":"PUBLISHED","datePublished":"2021-09-09T11:19:51.696Z","dateUpdated":"2026-04-28T16:07:36.029Z","assignerShortName":"Patchstack","assignerOrgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateReserved":"2021-07-19T00:00:00.000Z"},"containers":{"cna":{"title":"WordPress WP Google Maps Pro premium plugin <= 8.1.11 - Multiple Authenticated Persistent XSS vulnerabilities","descriptions":[{"lang":"en","value":"Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities in WordPress WP Google Maps Pro premium plugin (versions <= 8.1.11). Vulnerable parameters: &wpgmaps_marker_category_name, Value > &attributes[], Name > &attributes[], &icons[], &names[], &description, &link, &title."}],"affected":[{"vendor":"Code Cabin Inc","product":"WP Google Maps Pro","versions":[{"version":"8.1.11","status":"affected","lessThanOrEqual":"8.1.11","versionType":"custom"}]}],"references":[{"url":"https://www.wpgmaps.com/documentation/pro-changelog/","tags":["x_refsource_CONFIRM"]},{"url":"https://patchstack.com/database/vulnerability/wp-google-maps-pro/wordpress-wp-google-maps-pro-premium-plugin-8-1-11-multiple-authenticated-persistent-cross-site-scripting-xss-vulnerabilities","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Patchstack","orgId":"21595511-bba5-4825-b968-b78d1f9984a3","dateUpdated":"2026-04-28T16:07:36.029Z"},"credits":[{"lang":"en","value":"Original researcher - Vlad Visse (Patchstack Red Team)"}],"datePublic":"2021-09-08T00:00:00.000Z","solutions":[{"lang":"en","value":"Update to the 8.1.12 version."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"audit@patchstack.com","DATE_PUBLIC":"2021-09-08T11:52:00.000Z","ID":"CVE-2021-36871","STATE":"PUBLIC","TITLE":"WordPress WP Google Maps Pro premium plugin <= 8.1.11 - Multiple Authenticated Persistent XSS vulnerabilities"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"WP Google Maps Pro","version":{"version_data":[{"version_affected":"<=","version_name":"8.1.11","version_value":"8.1.11"}]}}]},"vendor_name":"Code Cabin Inc"}]}},"credit":[{"lang":"eng","value":"Original researcher - Vlad Visse (Patchstack Red Team)"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities in WordPress WP Google Maps Pro premium plugin (versions <= 8.1.11). Vulnerable parameters: &wpgmaps_marker_category_name, Value > &attributes[], Name > &attributes[], &icons[], &names[], &description, &link, &title."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":5.5,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"HIGH","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wpgmaps.com/documentation/pro-changelog/","refsource":"CONFIRM","url":"https://www.wpgmaps.com/documentation/pro-changelog/"},{"name":"https://patchstack.com/database/vulnerability/wp-google-maps-pro/wordpress-wp-google-maps-pro-premium-plugin-8-1-11-multiple-authenticated-persistent-cross-site-scripting-xss-vulnerabilities","refsource":"MISC","url":"https://patchstack.com/database/vulnerability/wp-google-maps-pro/wordpress-wp-google-maps-pro-premium-plugin-8-1-11-multiple-authenticated-persistent-cross-site-scripting-xss-vulnerabilities"}]},"solution":[{"lang":"en","value":"Update to the 8.1.12 version."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wpgmaps.com/documentation/pro-changelog/","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://patchstack.com/database/vulnerability/wp-google-maps-pro/wordpress-wp-google-maps-pro-premium-plugin-8-1-11-multiple-authenticated-persistent-cross-site-scripting-xss-vulnerabilities","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T01:01:59.798Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-03-28T16:56:01.623932Z","id":"CVE-2021-36871","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-03-28T16:56:07.811Z"}}]}}}