{"id":"CVE-2021-36044","state":"PUBLISHED","title":"Magento Commerce GraphQL Improper Input Validation Could Lead To Denial Of Service","description":"Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An unauthenticated attacker could abuse this vulnerability to cause a server-side denial-of-service using a GraphQL field.","publishedAt":"2021-09-01T14:32:31.895Z","updatedAt":"2024-09-16T19:57:02.192Z","severity":{"score":7.5,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","source":"adobe"},"assigner":"adobe","products":["Adobe Magento Commerce"],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.3.7","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":["https://helpx.adobe.com/security/products/magento/apsb21-64.html"],"weaknesses":["CWE-20"],"ingestedAt":"2026-10-29T19:48:44.655Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/36xxx/CVE-2021-36044.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-36044","state":"PUBLISHED","datePublished":"2021-09-01T14:32:31.895Z","dateUpdated":"2024-09-16T19:57:02.192Z","assignerShortName":"adobe","assignerOrgId":"078d4453-3bcd-4900-85e6-15281da43538","dateReserved":"2021-06-30T00:00:00.000Z"},"containers":{"cna":{"title":"Magento Commerce GraphQL Improper Input Validation Could Lead To Denial Of Service","descriptions":[{"lang":"en","value":"Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An unauthenticated attacker could abuse this vulnerability to cause a server-side denial-of-service using a GraphQL field."}],"affected":[{"vendor":"Adobe","product":"Magento Commerce","versions":[{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.4.2-p1","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"2.3.7","versionType":"custom"},{"version":"unspecified","status":"affected","lessThanOrEqual":"None","versionType":"custom"}]}],"references":[{"url":"https://helpx.adobe.com/security/products/magento/apsb21-64.html","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":7.5,"baseSeverity":"HIGH","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-20","description":"Improper Input Validation (CWE-20)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"adobe","dateUpdated":"2021-09-01T14:32:31.000Z","orgId":"078d4453-3bcd-4900-85e6-15281da43538"},"datePublic":"2021-08-10T00:00:00.000Z","source":{"discovery":"EXTERNAL"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"psirt@adobe.com","DATE_PUBLIC":"2021-08-10T23:00:00.000Z","ID":"CVE-2021-36044","STATE":"PUBLIC","TITLE":"Magento Commerce GraphQL Improper Input Validation Could Lead To Denial Of Service"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Magento Commerce","version":{"version_data":[{"version_affected":"<=","version_value":"2.4.2"},{"version_affected":"<=","version_value":"2.4.2-p1"},{"version_affected":"<=","version_value":"2.3.7"},{"version_affected":"<=","version_value":"None"}]}}]},"vendor_name":"Adobe"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An unauthenticated attacker could abuse this vulnerability to cause a server-side denial-of-service using a GraphQL field."}]},"impact":{"cvss":{"attackComplexity":"Low","attackVector":"Network","availabilityImpact":"High","baseScore":7.5,"baseSeverity":"High","confidentialityImpact":"None","integrityImpact":"None","privilegesRequired":"None","scope":"Unchanged","userInteraction":"None","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"Improper Input Validation (CWE-20)"}]}]},"references":{"reference_data":[{"name":"https://helpx.adobe.com/security/products/magento/apsb21-64.html","refsource":"MISC","url":"https://helpx.adobe.com/security/products/magento/apsb21-64.html"}]},"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://helpx.adobe.com/security/products/magento/apsb21-64.html","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T00:47:43.198Z"}}]}}}