{"id":"CVE-2021-3554","state":"PUBLISHED","title":"Improper Access Control vulnerability in the patchesUpdate API","description":"Improper Access Control vulnerability in the patchesUpdate API as implemented in Bitdefender Endpoint Security Tools for Linux as a relay role allows an attacker to manipulate the remote address used for pulling patches. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.6.27.390; versions prior to 7.1.2.33. Bitdefender Unified Endpoint versions prior to 6.2.21.160. Bitdefender GravityZone versions prior to 6.24.1-1.","publishedAt":"2021-11-24T14:45:12.904Z","updatedAt":"2024-09-16T20:03:20.270Z","severity":{"score":9,"label":"Critical","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","source":"Bitdefender"},"assigner":"Bitdefender","products":["Bitdefender Endpoint Security Tools for Linux","Bitdefender Unified Endpoint","Bitdefender GravityZone"],"affected":[{"vendor":"Bitdefender","product":"Endpoint Security Tools for Linux","versions":[{"version":"unspecified","status":"affected","lessThan":"6.6.27.390","versionType":"custom"},{"version":"unspecified","status":"affected","lessThan":"7.1.2.33","versionType":"custom"}]},{"vendor":"Bitdefender","product":"Unified Endpoint","versions":[{"version":"unspecified","status":"affected","lessThan":"6.2.21.160","versionType":"custom"}]},{"vendor":"Bitdefender","product":"GravityZone","versions":[{"version":"unspecified","status":"affected","lessThan":"6.24.1-1","versionType":"custom"}]}],"references":["https://www.bitdefender.com/support/security-advisories/improper-access-control-vulnerability-patchesupdate-api-va-9825"],"weaknesses":["CWE-284"],"ingestedAt":"2026-10-29T19:48:55.807Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/3xxx/CVE-2021-3554.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-3554","state":"PUBLISHED","datePublished":"2021-11-24T14:45:12.904Z","dateUpdated":"2024-09-16T20:03:20.270Z","assignerShortName":"Bitdefender","assignerOrgId":"b3d5ebe7-963e-41fb-98e1-2edaeabb8f82","dateReserved":"2021-05-17T00:00:00.000Z"},"containers":{"cna":{"title":"Improper Access Control vulnerability in the patchesUpdate API","descriptions":[{"lang":"en","value":"Improper Access Control vulnerability in the patchesUpdate API as implemented in Bitdefender Endpoint Security Tools for Linux as a relay role allows an attacker to manipulate the remote address used for pulling patches. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.6.27.390; versions prior to 7.1.2.33. Bitdefender Unified Endpoint versions prior to 6.2.21.160. Bitdefender GravityZone versions prior to 6.24.1-1."}],"affected":[{"vendor":"Bitdefender","product":"Endpoint Security Tools for Linux","versions":[{"version":"unspecified","status":"affected","lessThan":"6.6.27.390","versionType":"custom"},{"version":"unspecified","status":"affected","lessThan":"7.1.2.33","versionType":"custom"}]},{"vendor":"Bitdefender","product":"Unified Endpoint","versions":[{"version":"unspecified","status":"affected","lessThan":"6.2.21.160","versionType":"custom"}]},{"vendor":"Bitdefender","product":"GravityZone","versions":[{"version":"unspecified","status":"affected","lessThan":"6.24.1-1","versionType":"custom"}]}],"references":[{"url":"https://www.bitdefender.com/support/security-advisories/improper-access-control-vulnerability-patchesupdate-api-va-9825","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-284","description":"CWE-284 Improper Access Control","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Bitdefender","dateUpdated":"2021-11-24T14:45:12.000Z","orgId":"b3d5ebe7-963e-41fb-98e1-2edaeabb8f82"},"credits":[{"lang":"en","value":"Nicolas VERDIER, Cybersecurity Consultant at TEHTRIS"}],"datePublic":"2021-06-05T00:00:00.000Z","source":{"advisory":"VA-9825","discovery":"EXTERNAL"},"workarounds":[{"lang":"en","value":"An automatic update to version 6.6.27.390 fixes the issue."}],"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"cve-requests@bitdefender.com","DATE_PUBLIC":"2021-06-05T09:00:00.000Z","ID":"CVE-2021-3554","STATE":"PUBLIC","TITLE":"Improper Access Control vulnerability in the patchesUpdate API"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Endpoint Security Tools for Linux","version":{"version_data":[{"version_affected":"<","version_value":"6.6.27.390"},{"version_affected":"<","version_value":"7.1.2.33"}]}},{"product_name":"Unified Endpoint","version":{"version_data":[{"version_affected":"<","version_value":"6.2.21.160"}]}},{"product_name":"GravityZone","version":{"version_data":[{"version_affected":"<","version_value":"6.24.1-1"}]}}]},"vendor_name":"Bitdefender"}]}},"credit":[{"lang":"eng","value":"Nicolas VERDIER, Cybersecurity Consultant at TEHTRIS"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Improper Access Control vulnerability in the patchesUpdate API as implemented in Bitdefender Endpoint Security Tools for Linux as a relay role allows an attacker to manipulate the remote address used for pulling patches. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.6.27.390; versions prior to 7.1.2.33. Bitdefender Unified Endpoint versions prior to 6.2.21.160. Bitdefender GravityZone versions prior to 6.24.1-1."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":9,"baseSeverity":"CRITICAL","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-284 Improper Access Control"}]}]},"references":{"reference_data":[{"name":"https://www.bitdefender.com/support/security-advisories/improper-access-control-vulnerability-patchesupdate-api-va-9825","refsource":"MISC","url":"https://www.bitdefender.com/support/security-advisories/improper-access-control-vulnerability-patchesupdate-api-va-9825"}]},"source":{"advisory":"VA-9825","discovery":"EXTERNAL"},"work_around":[{"lang":"en","value":"An automatic update to version 6.6.27.390 fixes the issue."}]}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.bitdefender.com/support/security-advisories/improper-access-control-vulnerability-patchesupdate-api-va-9825","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-03T17:01:07.935Z"}}]}}}