{"id":"CVE-2021-34635","state":"PUBLISHED","title":"Poll Maker <= 3.2.8 - Reflected Cross-Site Scripting","description":"The Poll Maker WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the mcount parameter found in the ~/admin/partials/settings/poll-maker-settings.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.2.8.","publishedAt":"2021-08-02T20:39:20.859Z","updatedAt":"2024-09-17T02:51:45.027Z","severity":{"score":6.1,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","source":"Wordfence"},"assigner":"Wordfence","products":["AYS Pro Extensions Poll Maker"],"affected":[{"vendor":"AYS Pro Extensions","product":"Poll Maker","versions":[{"version":"3.2.8","status":"affected","lessThanOrEqual":"3.2.8","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34635","https://plugins.trac.wordpress.org/browser/poll-maker/tags/3.2.8/admin/partials/settings/poll-maker-settings.php#L249"],"weaknesses":["CWE-79"],"ingestedAt":"2026-10-29T19:48:38.863Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/34xxx/CVE-2021-34635.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-34635","state":"PUBLISHED","datePublished":"2021-08-02T20:39:20.859Z","dateUpdated":"2024-09-17T02:51:45.027Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-06-10T00:00:00.000Z"},"containers":{"cna":{"title":"Poll Maker <= 3.2.8 - Reflected Cross-Site Scripting","descriptions":[{"lang":"en","value":"The Poll Maker WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the mcount parameter found in the ~/admin/partials/settings/poll-maker-settings.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.2.8."}],"affected":[{"vendor":"AYS Pro Extensions","product":"Poll Maker","versions":[{"version":"3.2.8","status":"affected","lessThanOrEqual":"3.2.8","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34635","tags":["x_refsource_MISC"]},{"url":"https://plugins.trac.wordpress.org/browser/poll-maker/tags/3.2.8/admin/partials/settings/poll-maker-settings.php#L249","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.1,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-79","description":"CWE-79 Cross-site Scripting (XSS)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-08-02T20:39:20.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Xu-Liang Liao"}],"datePublic":"2021-07-26T00:00:00.000Z","solutions":[{"lang":"en","value":"Update plugin to version 3.2.9 or newer."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-07-26T06:00:00.000Z","ID":"CVE-2021-34635","STATE":"PUBLIC","TITLE":"Poll Maker <= 3.2.8 - Reflected Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"Poll Maker","version":{"version_data":[{"version_affected":"<=","version_name":"3.2.8","version_value":"3.2.8"}]}}]},"vendor_name":"AYS Pro Extensions"}]}},"credit":[{"lang":"eng","value":"Xu-Liang Liao"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The Poll Maker WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the mcount parameter found in the ~/admin/partials/settings/poll-maker-settings.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.2.8."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.1,"baseSeverity":"MEDIUM","confidentialityImpact":"LOW","integrityImpact":"LOW","privilegesRequired":"NONE","scope":"CHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-79 Cross-site Scripting (XSS)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34635","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34635"},{"name":"https://plugins.trac.wordpress.org/browser/poll-maker/tags/3.2.8/admin/partials/settings/poll-maker-settings.php#L249","refsource":"MISC","url":"https://plugins.trac.wordpress.org/browser/poll-maker/tags/3.2.8/admin/partials/settings/poll-maker-settings.php#L249"}]},"solution":[{"lang":"en","value":"Update plugin to version 3.2.9 or newer."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34635","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://plugins.trac.wordpress.org/browser/poll-maker/tags/3.2.8/admin/partials/settings/poll-maker-settings.php#L249","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T00:19:47.683Z"}}]}}}