{"id":"CVE-2021-34631","state":"PUBLISHED","title":"NewsPlugin <= 1.0.18  - Cross-Site Request Forgery to Stored Cross-Site Scripting","description":"The NewsPlugin WordPress plugin is vulnerable to Cross-Site Request Forgery via the handle_save_style function found in the ~/news-plugin.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.0.18.","publishedAt":"2021-08-05T19:36:40.504Z","updatedAt":"2024-09-17T02:15:47.427Z","severity":{"score":8.8,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","source":"Wordfence"},"assigner":"Wordfence","products":["NewsPlugin NewsPlugin"],"affected":[{"vendor":"NewsPlugin","product":"NewsPlugin","versions":[{"version":"1.0.18","status":"affected","lessThanOrEqual":"1.0.18","versionType":"custom"}]}],"references":["https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34631"],"weaknesses":["CWE-352"],"ingestedAt":"2026-10-29T19:48:38.863Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/34xxx/CVE-2021-34631.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-34631","state":"PUBLISHED","datePublished":"2021-08-05T19:36:40.504Z","dateUpdated":"2024-09-17T02:15:47.427Z","assignerShortName":"Wordfence","assignerOrgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599","dateReserved":"2021-06-10T00:00:00.000Z"},"containers":{"cna":{"title":"NewsPlugin <= 1.0.18  - Cross-Site Request Forgery to Stored Cross-Site Scripting","descriptions":[{"lang":"en","value":"The NewsPlugin WordPress plugin is vulnerable to Cross-Site Request Forgery via the handle_save_style function found in the ~/news-plugin.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.0.18."}],"affected":[{"vendor":"NewsPlugin","product":"NewsPlugin","versions":[{"version":"1.0.18","status":"affected","lessThanOrEqual":"1.0.18","versionType":"custom"}]}],"references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34631","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-352","description":"CWE-352 Cross-Site Request Forgery (CSRF)","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"Wordfence","dateUpdated":"2021-08-05T19:36:40.000Z","orgId":"b15e7b5b-3da4-40ae-a43c-f7aa60e62599"},"credits":[{"lang":"en","value":"Taichi Ichimura, Cryptography Laboratory in Tokyo Denki University"}],"datePublic":"2021-07-21T00:00:00.000Z","solutions":[{"lang":"en","value":"Uninstall the plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.0.9"},"x_legacyV4Record":{"CVE_data_meta":{"AKA":"Wordfence","ASSIGNER":"security@wordfence.com","DATE_PUBLIC":"2021-07-21T15:18:00.000Z","ID":"CVE-2021-34631","STATE":"PUBLIC","TITLE":"NewsPlugin <= 1.0.18  - Cross-Site Request Forgery to Stored Cross-Site Scripting"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"NewsPlugin","version":{"version_data":[{"version_affected":"<=","version_name":"1.0.18","version_value":"1.0.18"}]}}]},"vendor_name":"NewsPlugin"}]}},"credit":[{"lang":"eng","value":"Taichi Ichimura, Cryptography Laboratory in Tokyo Denki University"}],"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"The NewsPlugin WordPress plugin is vulnerable to Cross-Site Request Forgery via the handle_save_style function found in the ~/news-plugin.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 1.0.18."}]},"generator":{"engine":"Vulnogram 0.0.9"},"impact":{"cvss":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"HIGH","baseScore":8.8,"baseSeverity":"HIGH","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-352 Cross-Site Request Forgery (CSRF)"}]}]},"references":{"reference_data":[{"name":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34631","refsource":"MISC","url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34631"}]},"solution":[{"lang":"en","value":"Uninstall the plugin from WordPress site."}],"source":{"discovery":"EXTERNAL"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://www.wordfence.com/vulnerability-advisories/#CVE-2021-34631","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T00:19:47.356Z"}}]}}}